PuTTY Won't Login to Raspberry Pi

What is the problem?

I can't login to RPi via PuTTY terminal session. I have two PCs to work with, neither can get me in via PuTTY.

login as: pi
pi@192.168.86.87's password:
Access denied
pi@192.168.86.87's password:

login as: pi
pi@octopi.local's password:
Access denied
pi@octopi.local's password:

I just purchased RPi 3 B+ and did a fresh image on a new Sandisk 32GB micro SD card. Everything else works. I can print using Octoprint via web browser over WiFi, I can access and login to pi@octopi via direct keyboard/monitor interface.

What did you already try to solve it?

I followed Joe Mike Terranella's excellent YouTube tutorial series to image and configure.
Verified samba/smb.conf by doing
sudo testparm /etc/samba/smb.conf:
I would provide results, but I can't copy/paste since I can't get in via PuTTY.

Logs (syslog, dmesg, ... no logs, no support)

octoprint.log (154.7 KB)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

Pi: Raspberry Pi 3 Model B Plus Rev 1.3
Octopi 0.17.0
Octoprint 1.3.12
Printer: Alunar M505 with Anet V 1.0 board
Win 10
WiFi Router: Google Mesh - This is a relatively new mesh system. I was previously using a more conventional WiFi router. PuTTY SSH worked on my older RPi 3 B using the older router, maybe something with the Google router is blocking access?

I appreciate any help here, I've been reading forums for days now and I can't seem to find an answer, or even a troubleshooting path to follow.

Hello @rick.lingenfelter!

Maybe the Pi has another localisation than your keyboard has.
In minor case Z and Y are changed if you have a QWERZ keyboard.
If it French style, it may be more complicated.

If that were the case, I would not be able to login to the Pi with a direct keyboard connection. I am using the same QWERTY keyboard I was using on the PC (I don't currently have an extra one available).

I set locality to:
US #=United States

Your login session earlier is difficult for us to determine what's going on.

Did it seem to prompt for the password and then immediately say that access is denied? In that case, it's as if the keyboard is getting two RETURNS instead of one after you type pi [enter].

The default password for the pi user is raspberry unless you changed that at some point. It's a bit of a spelling test.

After inputting my password (I did change it), there's about a 2-3 second pause, then the Access Denied is displayed.
I am consistently able to login with the same keyboard via direct connect to the Pi.

Is there another log file I can pull using the Octoprint web interface that may provide some clues?

Maybe the PuTTY settings a mashed up?
I have these and they work fine:

grafik

Yes, those are the default settings, I haven't changed anything there.

Guessing: Change your password (locally) so that it doesn't have a double-quote character.

A good test is to type your password on the username prompt to verify that what you think you are typing is what you're actually typing.

login as: pi
pi@octopi.local's password: octopi

With a direct keyboard connection, make sure to go into sudo raspi-config, then go to interfacing options, SSH and make sure it's enabled, then reboot

1 Like

@5ft24 This sounds like a highly likely solution. I’ll try it this afternoon after work

1 Like

for fun, maybe someone can walk Rick through using telnet on Windows to see that it is responding?

@5ft24 Bummer, enable SSH via direct connect didn’t change anything. I had hopes for that one.

@tedder42, I installed Telnet on my Win 10 box , but I don't pretend to unerstand if I'm using it correctly:

you're close! do

open 192.168.86.87 22

OK, so it looks like something happened, but what next?

I may have just done something foolish - I have started the GUI interface download. I figured if I couldn't remote in, I would hook up BT KB & Mouse in the interim...

That's all we expect from Telnet- it proves that you can ssh to it remotely. So ssh is enabled; you need to figure out what the username and password is for the login- if you are connecting with a keyboard and monitor, presumably you know what it is.

I think I know what the problem has been all along. I am using a US keyboard on my laptop and Raspbian was still running default UK keyboard. when I finished installing the GUI, I reconfigured locality and keyboard to US. Rebooted, and now I can't login from anywhere, PuTTY or direct. the Pi is now expecting UK keyboard inputs for the password? I can't get into the thing to change the settings back - Catch-22! I may have to reimage and start over.

There ya go! If you look at us and uk keyboards you should be able to figure out what characters are wrong. You can rule out a-z, A-Z, 0-9, so if you only used a couple of special characters it shouldn't be too bad.