Python version 2.7.16 aftert fresh install 1.8

What is the problem?

After a fresh install of OctoPrint 1.8 on Raspberry Pi 4, I check the Python version and it is still 2.7.16.
Isn't it supposed to be 3.x?
Dis I miss a step somewhere? Or my lack of understanding gets in the way?

What did you already try to solve it?

I have reinstalled for a second time thinking the environment is back to 2.x because I install something else.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Haven't tried the Safe mode since this seems to be very rudimentary to the platform general provisioning.

How are you checking it? On the command line just via python --version? Because if so that is the reason. Default python running on 0.18 is default version still running on Debian, which at the time of writing is still python 2. However, OctoPrint runs from a python 3 virtual environment, and you can verify that by looking into the lower left corner of OctoPrint's UI where it reports both OctoPrint's and the Python version it's running under.

Also, this doesn't make sense. OctoPrint 1.8.0 is not released yet, I guess you mean OctoPi 0.18? Otherwise please clarify what exactly you installed how on what OS.

In any case, share a systeminfo bundle.

My bad... 1.7.3 with Octopi 0.18

But I think I got my answer.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.