Random disconnections

What is the problem?

I'm getting random disconnections, it says the printer seem dead. Could be 10hours or 5 min

What did you already try to solve it?

This has always been happening to me on both 0.17 and 0.18

  • Changed USB cables maybe 10 different cables
    edit- Removed pins from the usb cable to remove the 5v supply
  • Changed out official Pi 4 power supply with a canakit 3.5A power supply
  • Technically swapped motherboards 4.2.2 -> 4.2.7
  • wiggled the usb cables to see if that is the cause but its not
  • ran in safe mode
  • different firmware's

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No, unfortunately

Complete Logs

octoprint.log (175.5 KB) serial.log (331.9 KB)

Additional information about your setup

OctoPrint version-1.5.3 stable, OctoPi version - 0.18?, Ender 3 v2 with 4.2.7 board, firmware-jyers, browser-chrome, operating system - windows 10, ... as much data as possible

Hoping you might be able to spot the problem in the logs. Currently im just printing from the SD card as the failed prints are no fun.

You are running a Marlin development build. Can you please try with a stable build to rule out any issues with the development build?

To follow up on @foosel's comment, there was a semi-recent large refactoring of the serial communication in Marlin, and the developers are still tracking down various serial communications breakages due to that, specially in configurations with multiple serial ports defined (for example if you have a TFT display). So this may be related to that.


Thanks for having a look. I reinstalled the base Marlin I believe. The first print was good but the second print lost the connection mid SD print. Could you please have a look at the new log files?

octoprint2.log (64.2 KB)
serial2.log (3.7 MB)

I deleted some of the early text in the serial log as it was too big

Hey, sorry about the late reply. Can you think of a way to test that, would unplugging the screen help?

I just had a disconnection white printing with octoprint (not SD card printing) Don't know if these have more information as to why it is happening.

octoprint3.log (259.0 KB) serial3.log (3.5 MB)

I think I might have solved the issue. Short story: Grounding issue

Long story: I saw that some ender 3 v2's were suffering from layer shifting issues and creality suggested that the ground the Y axis motor to the frame and for some people it actually fixed the layers shifting issue so I thought I would give it a shot incase my board was somehow getting shocks from static build up. I ran a cable from the power supply to in between the stepper motor and frame and so far so good. No failed connections for 2 days so far.

1 Like