Random moves to same location during print

What is the problem?

When using Octoprint (1.7.3) running OctoPi (0.18.0) on a Pi3B+ (Python 3.7.3), I get random movements to the same locations during the print, where the print-head pauses for 1-2 seconds (oozing out some material) before continuing print. It seems to do this each layer depending on the shape.

What did you already try to solve it?

I ran in SAFE mode.
Then ran normally. Problem occurred again.
Then I disabled plugins some plugins which people had mentioned can cause issues with the print.

If the printer is connected to the computer through USB (not using RPi3+) the prints are do not have this issue.
Only occurs when running OctoPi/Octolapse in normal mode with plugins enabled.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:99.0) Gecko/20100101 Firefox/99.0 connectivity.connection_check: connectivity.connection_ok: True connectivity.enabled: True connectivity.online: True connectivity.resolution_check: octoprint.org connectivity.resolution_ok: True env.hardware.cores: 4 env.hardware.freq: 1200.0 env.hardware.ram: 914001920 env.os.bits: 32 env.os.id: linux env.os.platform: linux env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2 env.plugins.pi_support.octopi_version: 0.18.0 env.plugins.pi_support.octopiuptodate_build: 0.18.0-1.7.3-20220323100241 env.plugins.pi_support.throttle_state: 0x0 env.python.pip: 20.3.3 env.python.version: 3.7.3 env.python.virtualenv: True octoprint.safe_mode: False octoprint.version: 1.7.3 systeminfo.generator: zipapi System info bundle (Safe mode) [octoprint-logs (safe mode).zip|attachment](upload://AjLzi0q6EnrWf87LWeDUEfzPTMo.zip) (404.8 KB)

System info bundle (Normal mode: Plugins enabled)
octoprint-logs (Normal mode).zip (446.8 KB)

Plugins installed

Bed Leveling Wizard
Camera Settings (0.3.2)
Cancel Objects (0.4.7)
Cura Thumbnails (1.0.2)
Dashboard (1.19.8)
Detailed Progress (0.2.7) ---- Disabled
DisplayLayerProgress Plugin (1.28.0) ---- Disabled
DisplayProgress (0.1.3) ---- Disabled
Exclude Region (0.3.0)
GCode Viewer
Marlin EEPROM Editor (3.2.0)
OctoDash Companion (0.0.7)
OctoEverywhere! (1.6.6)
Octolapse (0.4.1)
PreHeat Button (0.8.0)
PrettyGCode (1.2.4)
PrintTimeGenius Plugin (2.2.8)
Resource Monitor (0.3.6)
SimpleEmergencyStop (1.0.5)
Slic3r (1.3.0)
Slicer Thumbnails (1.0.0)
Spoolmanager Plugin (1.7.0)
Filament Manager (1.9.1)

There are other standard plugins that installed with OctoPi/Octoprint.

Additional information about your setup

OctoPrint version 1.7.3, OctoPi version 0.18.0, Bukito, Marlin 1.0, Firefox, Win10,

The printer is similar to a Ender 2 (i think), or Prusa mini.
It has a custom Azteeg V2 board (8-bit I believe)
The Marlin software is Version 1.0. I am uncertain if it can even be upgraded to a later version.
At the moment I do not have a copy of the firmware to modify and test.
When printing from the computer instead, this print move does not occur. I'm using Repetier Host V2.2.2 for the computer driven control with a Slic3r for slicing.
Slic3r is used for slicing the files which are then saved and uploaded through Octoprint interface if I print with the RPi3 instead.
I have Cura 4.3 and Prusa-Slicer 2.4.1 but I have not set them up for this printer.

This is an copy of the Terminal log when the move/pause occurs (Normal mode)

Send: N1043 G1 X68.632 Y72.411 E4.3335688
Recv: ok
Send: N1044 G1 F8160.000
Recv: ok
Send: N1045 G1 X68.632 Y71.984 E4.1547388
Recv: ok
Send: N1046 G1 F8160.000
Recv: ok
Send: N1047 G1 X68.878 Y71.984 E4.0514886
Recv: ok
Send: N1048 G1 F8160.000
Recv: ok
Send: N1049 G1 X68.632 Y72.411 E3.8449892
Recv: ok
Send: N1050 G1 E1.33356 F3600.00000
Recv: ok
Send: N1051 G92 E0114
Recv: ok
Send: N1052 G1 X63.964 Y72.516 F10200.000
Recv: ok
Send: N1053 G1 E2.80000 F3600.0000035
Recv: ok
Send: N1054 G1 F4200.000
Recv: ok
Send: N1055 G1 X63.964 Y71.984 E2.8249190
Recv: ok
Send: N1056 G1 X63.452 Y71.984 E2.84888
Recv: ok
Send: N1057 G1 X63.759 Y72.516 E2.8776581
Recv: ok
Send: N1058 G1 X63.964 Y72.516 E2.88724
Recv: ok
Send: N1059 G1 X61.108 Y71.410 F10200.00082
Recv: ok
Send: N1060 G1 F4200.000
Recv: ok
Send: N1061 G1 X61.108 Y69.690 E2.9678290
Recv: ok
Send: N1062 G1 X60.268 Y69.690 E3.00717
Recv: ok

Hello @Silent_sound !

It looks you have Octolapse activated.

BTW: Safe Mode log is also included in the logs.

A question: Is your OctoPi username really ******** ?

Thanks for the reply.

Octolapse plugin but turned off in the octolapse tab. Do you think it is somehow still doing something?
While problem solving a more sever version of this pausing which resulted in frequent jamming i would get a dialog before print could start. It was one of the reasons I turned it off in the Octolapse tab. I will try disabling the plugin and try a print again.

On the OctoPi naming thing, ******* is not the name. I have a program that automatically removes username, logins, passwords etc from any file when they are uploaded, Seems it must have noticed the OctoPi username and blanked it out. That was unexpected..

Have disabled Octolapse plugin. The move to the center of the print does not occur.
If the Octolapse plugin is enabled, but the Octolapse is turned 'off ' in the tab, is there a reason for why it may still cause this behavior?

I still get some pauses every 2 layers, elsewhere in the print, for layers <10. Also 3-4 pauses near layer 10, then seem to print normally without pauses after that. Note: these pauses are not the same as the previously described pause above.

If it is ok in safe mode, you have to find the 3rd party culprit by try and error.
With that amount of plugins quite an effort.
Maybe disable the fist half. It it is ok then, the culprit is in that half, else in the second half.
Then you can half the first half to do it again etc. Quite recursive.

Ewald_Ikemann, your right. I've started going through each with the 3rd party plugins turned off, and slowly enabling them in groups of 2-3. I am curious to locate the one causing the issue(s).
If you or anyone else has an idea on which ones are likely to not be contributing to the problems, your ideas would be appreciated.
I would very much like to get this working smoothly.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.