Random pauses causing "zits" all over prints, mostly on walls

What is the problem?

I am getting horrible "zits" or "blobs" all over my prints caused by random pauses that are not planned, so no retraction or z-hop, and it appears to be mostly on walls. From watching the terminal and looking at the logs it appears it occurs whenever this message posts (I can visually tell this is what's causes the pauses).

Communication timeout while printing, trying to trigger response from printer. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.

I've not been able to decern a pattern for when it occurs, all of the plug-ins I use were one's I used in the past, but I'm guessing it's one of them since the issue does not occur in safe mode. On a 7 hour print there were probably 200 zits on the inside/outside walls.

FWIW, I recently had to start from a fresh load of Octoprint and plug-in installs. The printer (Ender 3 Pro) ran pretty flawlessly for a couple of years, but I had not used my printer for a few months (basement remodel) and when I tried to bring the system back up nothing would happen. Actually, anytime I shutdown the Rpi now, even with a clean shutdown command, if I then cut physical power to it the device Octoprint will never fully boot back up and it requires me to reload everything and restore from octoprint backup (native B&R). I think that issue is totally unrelated to the zit/blob though, so I plan to open a separate issue for that.

What did you already try to solve it?

I've search the forums/reddit exhaustively and tried adjusting Octolapse settings and then totally disabled Octolapse, as the forums lead me to think that was the cause but it's still occurring.

I've also tried different USB cables and power adapters, even isolated the printer by itself on a house circuit to try and rule out electronic interference or cable/plug hardware issues, and none of that fixed the issue (note, every cable/plug setup I tried required me fully reloading/restoring Octpi due to other issue noted above, so I've spent a lot of time trying to troubleshoot this issue).

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Yes, which is also why I feel like it's not a cable/HW issue.

Systeminfo Bundle

octoprint-systeminfo-20230818201813.zip (1.0 MB)

Additional information about your setup

OctoPrint version = 1.9.2
OctoPi version = Version 1.0.0, running on Raspberry Pi 3 Model B Rev 1.2
Printer = Ender-3 Pro V1.5
Firmware = Marlin bugfix-2.0.x 2021-05-19
RaspberryPi 3B+
Browser = Chrome Version 115.0.5790.171 (Official Build) (64-bit)
OS = Windows 11 (but that's my PC that I just use Windows/Chrome for remote access, OctoPrint runs on my Rpi)

your logs unfortunately didn't capture the time when you were running in safe mode. I do notice that you have octolapse and displaylayerprogress plugins, which both are known to cause defects for different reasons. after restarting in safe mode did you reupload a gcode file and try with that? the reason I ask is because DisplayLayerProgress plugin actually modifies your uploaded file.

1 Like

@Nolemgib, as you post this, I've just today finished fighting a similar problem on an Octopi & Ender-3 V2 configuration that has worked flawlessly for 3+ years through Octoprint/Octopi/Marlin upgrades to current stable releases. Nary a blob was ever seen. I recently started testing OctoEverywhere & Octoapp plugins on Octoprint. If I disconnect wifi from my Android phone & force the connection to Octoapp remotely through OctoEverywhere, the blobs begin to appear in simple prints started from Octoprint.

@jneilliii is clairvoyant to highlight the DisplayLayerProgress plugin in this case as a potential cause. Safe mode worked perfectly & started me down the path of plugin testing. The solution, in my case, was disabling the Enable WebSocket-Communication setting in the DisplayLayerProgress plugin. All has returned to normal with all plugins peacefully co-existing and no blobs. I see from your bundle that you are using all three.

Thanks @jneilliii!

The issue of it not starting back up after a clean shutdown would seem to be the SD card starting to have issues


I used the same file in safe mode, did not re-upload. Worked fine in safe mode. I will look at the other recommendations posted.

Ironically, or maybe not, changing the SD Card fixed all of my problems. No more zits/warts and shutting down Pi does not wipe out the Pi. Didn't think the SD card could cause the kind of issue I was having with random lags, but I guess it was the cause as that's the only change I made and the same print is now operating perfectly.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.