Random printer stops during print

What is the problem?

When printing the print stops, sometimes this is for just a second or so and sometimes for minutes
I have tried a simple print "XYZ Cube" and it has even stopped while printing the skirt

What did you already try to solve it?

Changed the power supply for a genuine Pi Charger
Changed the USB Cable to the printer
Print from SD Card or Local saved files
Prints OK directly from printer not using octoprint
Print in Safe mode
I have only had Octoprint for 2 weeks and had no successful prints yet as its new it could be I'm missing something but don't think so

Have you tried running in safe mode and if so did it solve the issue?

Safe mode made no difference

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Logs attached

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0.1 Safari/605.1.15
connectivity.connection_check: 8.8.8.8:53
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 3928301568
env.os.bits: 64
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.2.4
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: true
octoprint.version: 1.5.1
printer.firmware: Marlin 2.0.6.1 (Nov 29 2020
octoprint-2.log (155.7 KB) serial-2.log (2.2 MB)

Have you tried without the SD card in the printer?
There are already 100 files in the trash folder there.

No but I will now

Tried without SD card in printer and stopped printing on layer 3

Thanks for the suggestion it was worth a try

So at every layer change there is this:

2020-12-07 14:05:00,116 - Send: N1463 M117 Printing xyzCalibration_cube - Layer 10 of 100*45
2020-12-07 14:05:00,118 - Recv: ok
2020-12-07 14:05:00,122 - Send: N1464 G1 F300 Z2*2
2020-12-07 14:05:00,230 - Recv: ok
2020-12-07 14:05:00,243 - Send: N1465 G0 X3.500 Y346.500 F4800.000*104
2020-12-07 14:05:01,298 - Recv:  T:200.14 /200.00 B:60.42 /60.00 @:57 B@:0
2020-12-07 14:05:02,245 - Recv: echo:busy: processing
2020-12-07 14:05:03,299 - Recv:  T:200.10 /200.00 B:60.39 /60.00 @:58 B@:0
2020-12-07 14:05:03,786 - Recv: ok
2020-12-07 14:05:03,788 - Send: N1466 M400*18
2020-12-07 14:05:04,790 - Recv: ok
2020-12-07 14:05:04,792 - Send: N1467 M114*19
2020-12-07 14:05:04,799 - Recv: X:3.50 Y:346.50 Z:2.00 E:220.35 Count X:280 Y:27720 Z:1489
2020-12-07 14:05:04,801 - Recv: ok
2020-12-07 14:05:05,044 - Send: N1468 G0 X90.916 Y95.260*28
2020-12-07 14:05:05,300 - Recv:  T:200.10 /200.00 B:60.37 /60.00 @:58 B@:0
2020-12-07 14:05:07,045 - Recv: echo:busy: processing
2020-12-07 14:05:07,303 - Recv:  T:199.91 /200.00 B:60.31 /60.00 @:63 B@:0
2020-12-07 14:05:07,544 - Recv: ok

There is M400 to wait for to finish the last move.
Do you have Octolapse running?

1 Like

I did yes but after turning it off and running in safe mode the same stopped printing still happens

Can you share the logs from safe mode?

Looks like logs turned off when I put in safe mode, I will turn back on and rune another print

1 Like

Looks like I get this message in terminal when print stops

Send: N630 G1 F2100 E93.6497354
Recv: T:209.92 /210.00 B:60.24 /60.00 @:50 B@:127
Recv: T:209.65 /210.00 B:59.61 /60.00 @:59 B@:0
Recv: T:210.39 /210.00 B:59.66 /60.00 @:41 B@:0
Communication timeout while printing, trying to trigger response from printer. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.
Send: N631 M105
35
Recv: ok T:210.39 /210.00 B:59.66 /60.00 @:41 B@:0
Send: N632 G1 F2700 X90.366 Y79.052 E93.6705257
Recv: ok
Send: N633 G0 F13500 X90.366 Y79.618
116

serial-3.log (283.0 KB) octoprint-4.log (32.3 KB)

Latest Logs can't get logs in safe mode don't know why

Try isolate the 5v power connection (inside USB cable) from raspberry to printer.
There could be an issue when both have there own power supply.

You can try to significantly increase the timeouts. I had to do that for my printer a long time ago to avoid print crashes.

Thanks to all those who suggested a fix, the problem turned to be a faulty printer board..

Thanks to bigtreetech for refunding the cost of the board and help in finding th3 cause of another problem that was also the board