Randomly Webinterface offline but continous Printing

What is the problem?

Raspberry Pi 4 2gb RAM

Since Octoprint 0.18.0 while printing, randomly my webinterface is offline. Sometimes after 30 Minutes of printing, sometimes after 4 hours - it is not a fix time.

Suddenly the Webinterface is offline! But the printing goes on and finishes proberly. If the webinterface is offline - i cant reach Octopi over Browser and Putty(SSH) ping the Raspberry isnt working too.
Before there are no Problems like this.

Sometimes i noticed, the webcam stream is stuttering/lagging before the Webinterface goes offline.

What did you already try to solve it?

Installed Octoprinted completly new and tried the newsest nightly.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Additional information about your setup

0.18.0, Ender 3 Pro with TH3D Firmware,Windows 10 and Android 10, Real Power Supply

Have you tried to reload the web GUI?

Sounds like the wifi connection is not that great - this may not be your issue, sometimes the Pi 4's wifi can crash.

What can you do to solve it? A wired connection won't have these issues. You can also check the syslog or kern.log (under /var/log) to see if there are error messages about the wifi, to be sure this is the problem.

I too have recently had this issue and am in the process of debugging troubleshooting as my other pi4 has been working flawlessly without issue. I have started by reflashing octopi 0.18 and removing the pi from my case. During my research I did find something related to wifi dropping out if connected to a hi res HDMI display causing signal noise for 2.4GHZ on channel 1. The workaround was to make your router use a higher channel or connect to 5GHZ wifi.

Sure. But no chance.

The Router is about 5 Meters away from the Rapsi - no wall or something. But yes - good idea - i will try a wired connection and see how it works. Thank you

1 Like

the only thing i don´t understand is- before 0.18. Octopi --- i works realy great - no issues. And i changed nothing - same wifi - same wifi channel - some distance to router - everything is the same except the Version of Octopi. But i will try i a wired connection and see if this will solve the Problem.

Sounds like you the understanding - it's OctoPi 0.18 that is the difference.

The image is based on Raspberry Pi OS, which you can update using sudo apt update and sudo apt upgrade from the console. It's fully possible that there is a bug with the wifi module in the latest versions. Worth a try to update it to see if there's anything that needs updating.

okay. i flashed a newer nightly instead of update/upgrade. Then i ll try this before trying a wired connection. i will report but have to wait till the print is ready :slight_smile:

Hi Everybody. Update and Upgrade didn´t solve the Problem - :frowning: . Next try is a wired connection. I will tell you the Result.

So I've been getting this with my newer Pi 4 recently as well. So far the following has helped, but it still hasn't been running that long to know for sure.

sudo rpi-update
sudo apt update
sudo apt upgrade

This will install the "latest" kernel drivers available that may be newer than the "stable" release and may have unknown side effects that I haven't uncovered yet, but so far it's looking promising.