Rasberry Pi4B 2GB - No Wireless Interface found

What is the problem?

I first had issues installing 0.17.0 with the 'device not supported' error that apparently can happen on the latest boards pi4 boards.

So I'm now trying to install the OctoPi 0.18.0rc1 (tried both 32bit and 63bit).
After configuring the wpa supplicant file (using notepad ++) and installing 0.18 I can't see the Raspi on my wireless network.

So I tried sudo raspi-config > Network Options > N2 Wireless Lan.
I get the error 'No Wireless Inteface Found'

I then try sudo iwlist wlan0 scan
and get the error 'wlan0 inteface doesn't support scanning'.

What did you already try to solve it?
I've re-read the instructions and scoured the forums for similar issues but I cannot resolve this.
I've tried reflashing multiple SD cards (8gb and 16gb) with 32&64bit 0.18.

I even renamed my SSID and removed the '-' in case that was causing issues.

Logs (syslog, dmesg, ... no logs, no support)
Sorry, I'm a noob at this so please let me know what network logs I need to provide.

Supplicant file contains the following:

WPA/WPA2 secured

psk="password removed but is correct"
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

Note: the actual supplicant file contains all of the commented out text, but I've only copied here the uncommented text.

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

I'm just running the out of the box BT Home Hub setup, the bands were combined but I've since tried splitting out 2.4g and 5g bands to see if that helped.

Before we spend any more time on Octopi, I've just tried installing the standard Raspberry Pi OS and i've got similar wifi issues (No Wirelss LAN Intefaces found), so I've raised a ticket with the shop I bought it from (thepihut), in case there's an issue with the board.


1 Like

Should anyone else encounter the same issue, after speaking to the shop where purchased it from, they assumed it was a faulty WiFi chip and I got a replacement.

Replacement works as expected.