Raspberry cam module V2 too zoomed in

What is the problem?

Hello, I am running Octopi on a raspberry pi 4b. I installed a webcam and manage to get the feed on octoprint.

However, the camera is too zoomed in. Is it possible to configure the camera and zoom it out?

I am very new to all this, my knowledge goes as far as reading the forum and try the proposed solution.

I acces my raspberry pi by connecting my monitor and a keyboard on it. Only Octopi is installed

Thank you for your help.

What did you already try to solve it?

I try to find a thread with same issue but no luck. I tried to get in touch with touch with raspberry pi people but no luck

Have you tried running in safe mode?

I dunno what that is

Did running in safe mode solve the problem?

WRITE HERE

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint version: 1.9.3
Octopi version: Build 2023.07.20 144556 with “camera-streamer”, based on OctoPi 1.0.0, running on Raspberry Pi 4 Model B Rev 1.5

I believe I had the same issue and I modified /boot/camera-streamer/libcamera.conf as included below. I commented the original lines and added new values. It is not exactly the same image as I had on OctoPi 0.18.0 but its close enough.

### Options for libcamera based cameras (PiCam, Arducam, ...)

# The port on which the webcam server for the camera should listen on. If you have only
# one camera, leave at 8080. If you have more, change to 8081, 8082, etc. The primary
# camera will be considered the one with 8080.
PORT=8080

# The resolution to request on the camera sensor. Defaults to 1280x720.
# WIDTH=1920
WIDTH=3280
# HEIGHT=1080
HEIGHT=2464

# The height to use for the video stream. Defaults to 720.
# VIDEO_HEIGHT=720
VIDEO_HEIGHT=1080

# The height to use for the snapshots. Defaults to 1080.
# SNAPSHOT_HEIGHT=1080
SNAPSHOT_HEIGHT=1080

# The framerate to set on the camera. Defaults to 15fps.
FRAMERATE=15

# Additional options. By default enables continuous auto focus (if possible).
OPTIONS='--camera-options="AfMode=2" --camera-options="AfRange=2"'

I run my OctoPi systems (RPi 3B with RPi camera V2.1 and RPi 4B with RPi camera V3) headless and use PuTTY (on Windows 10) to communicate using SSH. I also use WinSCP to move files around.

If you are not using Windows, there are SSH (and SCP) clients on just about every OS. Let us know if you need additional instructions (and for what operating system).

Thank you very much for your reply and solution. My printer is printing now so I will try it right after. I Have a monitor and a key to my raspberry pi only. When I log in, shall I just paste the code your proposed? I do not run Putty or anything else, I am on MAC, I found it more easy to just plug a keyboard and screen to my pi :slight_smile:

If I had room for a monitor, keyboard, and mouse next to my 3D printer, I probably would have never found OctoPrint (and OctoPi)! In any case, MacOS has an SSH client and you can find instructions on the web (and probably in this forum) if you want to try it.

Yes, you can just paste my code.

Hello :slight_smile:

I enabled ssh on my raspberry and started using the ssh client, thank you for that tip, makes things so much easy when learning the commands and stuff.

I logged in to my raspberry pi, pasted your code and reboot my raspberry pi, I checked the imade and it did not change. I read alittle more about the raspberry cameras and found out infos about my system.

I ran a libcamera-hello command (after running sudo apt-get update) and what I received is the following:

Made DRM preview window
[0:30:46.705952285] [2455]  INFO Camera camera_manager.cpp:297 libcamera v0.0.5+82-2783c8d8
[0:30:46.718926764] [2456] ERROR V4L2 v4l2_device.cpp:353 'imx219 10-0010': Unable to set controls: Device or resource busy
[0:30:46.730727791] [2456]  WARN RPI vc4.cpp:383 Mismatch between Unicam and CamHelper for embedded data usage!
[0:30:46.731514950] [2456]  INFO RPI vc4.cpp:437 Registered camera /base/soc/i2c0mux/i2c@1/imx219@10 to Unicam device /dev/media0 and ISP device /dev/media2
[0:30:46.731580505] [2456]  INFO RPI pipeline_base.cpp:1101 Using configuration file '/usr/share/libcamera/pipeline/rpi/vc4/rpi_apps.yaml'
[0:30:46.731880780] [2455]  INFO Camera camera.cpp:840 Pipeline handler in use by another process
ERROR: *** failed to acquire camera /base/soc/i2c0mux/i2c@1/imx219@10 ***

The direct camera support comes from libcamera and in the OctoPi case, camera-streamer is the application that grabs the camera and interfaces with OctoPrint.

There are topics in this forum that discuss how to turn camera-streamer on and off and how to make libcamera to do the same. I just made the changes to the .conf file, rebooted and I was happy.

Ah ok, I am completely in the lost then. I find out how to modify the .conf file and try your code again :slight_smile:

Hello! I think I made it work! hahaha Thank you very much for your help, made my day to have a great quality image :slight_smile: