Raspberry Camera v3 not working on Pi Zero 2 W

Camera model

Raspberry Pi Camera Module 3

What is the problem?

“Stream not loaded” on Web UI

What did you already try to solve it?

Reading thru Forums. Getting Help.


  • checking connections (CSI,PSU)
  • replacing all the Hardware (Boards, Cables, Module, PSU, SD-Card)


  • reflashing multiple times using RP-Imager (new Stack latest as of 07.04.2024)
  • running commands “apt-get update/upgrade/..“
  • modifying the libcamera.conf (i did try “--http-listen=” and various resolutions/fps/)
  • restarting services (camera-streamer)

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (fresh install only changes are to Network (wifi) and Names)

octoprint-systeminfo-20240408154546.zip (13.3 KB)

After Upgrading from my RP zero W (with RP Cam v2) to -> RP zero 2 W (with RP Cam v2)
the Cam never seemed to work well but it did work (old Stack cant remember the version). Then i ran “apt-get update/upgrade” and the camera stopped working. Started to troubleshoot and decided to upgrade to the new Octopi Stack and the new RP Cam v3 never got it to work.

“vcgencmd get_camera” output:
supported=1 detected=0, libcamera interfaces=1


from “camerastack-journal” last 4 lines:

[0:00:18.916547074] [621] WARN V4L2 v4l2_videodevice.cpp:2007 /dev/video0[24:cap]: Dequeue timer of 1000000.00us has expired!
[0:00:18.916713064] [621] ERROR RPI pipeline_base.cpp:1333 Camera frontend has timed out!
[0:00:18.916757491] [621] ERROR RPI pipeline_base.cpp:1334 Please check that your camera sensor connector is attached securely.
[0:00:18.916800564] [621] ERROR RPI pipeline_base.cpp:1335 Alternatively, try another cable and/or sensor.

Additional information about my setup

OctoPrint version 1.9.3, OctoPi version 1.0.0, MK3S+, Safari (latest)
edit: Typo and log for convenience


I bought a new RP02w Board and that just worked !

Using the same SD-Card/Image/Cable/Configs/…

It seems multiple of my Boards are having the same HW related issue that leads to the Camera not working.

I am using the somewhat outdated “Power-Delivery directly over the MK3,s Einsy-Rambo” via Pins. There might be complications related to Heat/Power i am not aware of ?