Raspberry Pi 3 Model b+ - Green light don't blink

Hello Guys.
Nice to meet you all :slight_smile:

I apologise for the much discussed topic, but I've been reading everything regarding this and decided to reach out, since everything I tried does not work.

I bought a Raspberry 3 b+ to connect to my ender 3 Pro, following all the tuts and advices I could find online. After some frustrated attempts I finally (after 2 days) put everything running... The raspberry, the Pi cam... everything needed to run the machine remotely.

Unfortunately it only lasted 10 minutes. I switched off the RaspPi and connected a longer camera cable.
Now the green light don't turn on (never) and I already tried 4 new sd cards, reinstalled octoprint, etc.
The red light stays on and the cooler fan attached to the board works, so I think the RaspPi board is ok...

But I'm not tech savvy, so I really don't know how to test it.

I don't have any logs. The Raspi don't show on the router, so no connection.

Raspberry Pi 3 Model b+
Running last octoprint version (0.16) with an Ender 3 Pro.
Mac OS
Browser - Chrome

Cards from SanDisk (16GB)
Original Raspberry power supply
Good USB cable

If anyone has some advice, I really appreciate it.


Hi @Paulo_Faria!

Have you tried with the camera cable detached from the Pi?

Hi Ewald.
Thanks for your reply.

I did. One of the advices I read was to detach every peripheral from the Pi.
No luck.

The green LED indicates activity. Presumably you have power. You might try visiting your network router, review Attached Devices and see if the octopi shows up. It likely has not received an IP address. If it has, then remote into it and see what's going on.

I'm guessing, though, that it's possible that it's done a kernel panic and has stopped. Or maybe it's simply not received an IP address because the wifi configuration isn't happy.

  • Try attaching a keyboard/mouse/monitor to the Pi. See what it's trying to say when it boots.
  • Try attaching an Ethernet cable. If the problem was the wifi setup then you'd know. I'm pretty sure that the 3B+ supports 5Ghz wifi so maybe it's connecting to a zone that's not setup on your router correctly.
  • Consider dedicating an IP address to the Pi on your network router's DHCP server.

Hello OutsourcedGuru.

Thanks for your reply.

I just edited the text above saying that I don't have the Octopi connected on the router. Does show up but Offline. I could connect one time, before this happened, but now appears offline.

I will try the other options you gave, but does it boot with the octoprint installed, or do I have to install some other kind of bootable system?


With the OctoPi image it's supposed to boot, connect to the network, make itself useful by running OctoPrint and haproxy, optionally load the webcam stream, etc. It sounds like yours may have problems booting up.

No connection with an ethernet cable :frowning:

Well then it doesn't boot.
Are you sure you inserted the sd card the right way?

I would put a monitor/keyboard/mouse on the Pi so that I could see the kernel panic (likely) that's preventing it from booting up. If you have another microSD install a new OctoPi image on that and see if that will boot (having followed the instructions of course).

I did yes :slight_smile: