Raspberry Pi 4 is out

Thanks for the quick response, very helpful. Done, up and running.

1 Like

Hi all,
I have RPi4B now from a week or two and I'm playing with this current Octopi image. Setting the Octopi was almost without problems and everything was solved one way or another, but now I'm facing a bit strange issue.
Here is my setup:
octopi-buster-lite-0.17.0.img setup for Prusa I3 Mk3S with Enclosure plugin. (I update it daily)
As an addition I have an OpenVPN running so I can access the server from outside.

After booting the RPi everything works perfect: I can access the Octopi server from my internal network as well as through my phone (in 4G mode) by using the VPN.

The issue:
After some amount of time (2-3-5 hours) I no longer can connect to the Octopi server through my internal network, but with some continuous tries I'm able to connect to the VPN server and to connect through it to Octopi. Even when I can do that I still cannot connect directly through my internal network. There are even cases when my PC and phone a connected to the Wifi (so they are in the internal network) the PC can reach RPi, but the phone not.
The bottom line is that after 2-3-5 hours some variants for reaching the RPi might work (with significant amount of attempts) and others not.

I used this method to disable the power management of the Wifi adapter:

by its own and along with "sudo iwconfig wlan0 power off", but without effect on the issue.

I'm having the same configuration on RPi Zero W on which I don't have any issues - neither with Octopi nor with OpenVPN.

The connection of the wlan0 looks like that:
wlan0 IEEE 802.11 ESSID:"fhnt"
Mode:Managed Frequency:2.412 GHz Access Point: xxxxx
Bit Rate=150 Mb/s Tx-Power=31 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=61/70 Signal level=-49 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:51 Invalid misc:0 Missed beacon:0

Any ideas how to troubleshoot or solve this issue would be very appreciated.
Thank you.

It looks like it's sometimes having difficulty talking to the wifi router. You should run an ifconfig locally on the Pi to check the flags on the wlan0 adapter when it's acting up. You can put a display/keyboard/mouse on the Pi temporarily while troubleshooting.

It sounds like you're connecting to the 2.4Ghz wifi zone. Note that the Pi4B also can support 5Ghz, for what it's worth. I don't think it's wifi adapter power management; I don't think the Raspberry Pi Foundation would be stupid enough to fall back to that problem again.

You didn't indicate what kind of PC you have (Windows/macOS, etc). You didn't indicate if OpenVPN is also running on the Pi4B.

You might check your DHCP lease length on your router's admin page. It's possible that it's short-leasing to some ridiculous level. You'd think it wouldn't be this, though.

If you workstation is Windows it's possible that for this one it's related to the arp cache and its absence of the Bonjour name resolution service.

Unfortunately I don't have proper cable for connecting a monitor to the RPi.

Yes, my network is 2.4GHz. The router is quite old now (D-Link DIR-605L), but I didn't have any issues with the RPi Zero W. The RPi4 just replaces the RPi Zero W. No position or anything else changed.

My PC is running WIndows 10, and the OpenVPN running is on the RPi.

DHCP lease time is set at 1440 minutes.

As I said, my PC is with Windows, but I'm having same problems with my phone (Android 9, with JuiceSSH).

Now I put a range extender close to the RPi, connected the RPi to it and will share results in a couple of hours.
(EDIT: the issue is persistent. It's not affected at all from the range of the WiFi)

1440 / 60 = 1 day so it is entirely possible that the lease is running out during all this. Why not just dedicate an IP address to this Pi and not have to deal with the worry?

Neither Windows nor Android runs Bonjour by default. It might require some trickery to get this to behave.

Personally, I've had my own wifi quality go bad over time and it had zero to do with my own equipment; over that period of time my apartment neighbors had installed competing wifi zones (about 30 within reach). So sometimes it's just the landscape, so-to-speak. I had to install a pair of Orbi routers (from Netgear) and that sorted things out for me.

Try an Ethernet cable for a bit.

The RPi has a dedicated IP. I did that in the very beginning. It's assigned to the MAC address in the router.
If I assume I that the problem is with the router and the landscape, I don't have explanation why this doesn't happen to the RPi Zero W which was previously installed there.

Today I tried with clean install of Raspbian. And it's the same.

Will check how it's with a cable.

have you tried updated the Raspbian underneath the octoprint, I did a new build today and got a pre-release version of buster which really didn't like the wireless on the pi4

I ended up using a cable to get it sorted, then revert to wireless

I had to
put the SD card in a pi3b to fix it
apt -y update
that got an initial update but all sorts of things broke
sudo dpkg --configure -a
to fix a number of packages
then run the update again and I needed another command to fix that (apt-get --fix I think it was, it told you the command needed in the error)
then it finally ran the sudo apt-get update and the sudo apt-get dist-upgrade
then I could finally get the wireless to configure (remember pi3b can only see 2.4ghz wireless, pi4 can see both 2.4 and 5ghz wireless)
now the card is back in the pi4 4gb and running fine, far quicker and smoother running octopi

1 Like

one other thing I noticed was with my ANET A8 with the factory firmware (yes I am aware of the lack of thermal runaway protection) if I plugged the USB cable to the printer into the blue USB 3 ports on the Pi4 it failed to boot until I moved the USB to one of the USB 2 ports


Raspberry pi4 problem (solved)

1 Like


I thought it may be power related, as the USB 3 ports can provide more power then the USB 2 ports

and mine has the USB C power issue (1 instead of 2 resistors in the detection circuit) so wouldn't surprise me if there weren't a few more USB bugs with the USB 3 ports

but plugging into the USB 2 ports works fine :slight_smile: so is an easy fix instead of having to tape a fiddly bit inside a USB plug

my octoprint wifi works great no issue at all, but i put official 7 inch raspberry touch screen on RPi4 4gb. I want boot to desktop to load the browser but seen cant work at all.

i already install plugin "TouchUI" still cant work.

i try this command still cant work at all

  1. sudo /home/pi/scripts/install-desktop
  2. sudo raspi-config -> Boot Options -> automatically boot to GUI as pi user
  3. sudo apt-get install lightdm

here is the image of scripts........

Uhm no that aren't your images. maybe the last one ist but the others are from the user @Clbyrd77.
What is your deal !?

Are you sure your pi can reach the internet?
and the fix missing command is sudo apt-get install --fix-missing in your case

yes, it connected to wifi.

I tested one of the files that your pi can't reach and it works for me.

Just to be sure your pi can reach it too and there is another problem try this

wget http://raspbian.raspberrypi.org/raspbian/pool/main/i/initramfs-tools/initramfs-tools_0.130_all.deb

Still not working see the image below.

Then come back to this.

well you didn't paste the full link - you just entered the first part.
the full link is http://raspbian.raspberrypi.org/raspbian/pool/main/i/initramfs-tools/initramfs-tools_0.130_all.deb

Still not working.

When I run sudo apt-get upgrade, I get errors that components are not found. I can complete the process with sudo apt-get install --fix-missing but this should not be necessary. I somenting messed up in the 0.17.0 build?

try sudo apt-get update --allow-releaseinfo-change and test if it works afterwards

Well, that's a new one on me. So this build was made before Buster was officially released, I suppose.

Thanks, that fixed it.

1 Like