Raspberry pi4 problem (solved)

When I try to print a gcode file,few seconds then disconnected,and shows up this message, please help, using Raspberry pi 4 with Ender 3.And other question , When I plug in the pi camera ,or connect a fan ,then can not boot,the green led didn't flash .Thanks for help!

Sounds like an undervoltage issue when you plug the camera in. Try a different power adapter and usb cable. If not then try powering it from the 5V pin (use caution).

1 Like

thanks for replay,I’ve try many USB power and cable doesn’t work, I also installed Raspbian OS to test the camera , same results can’t boot the OS unless unplug the camera, maybe it’s damaged.The fan problem is my mistake to put in the wrong pin.
Now the biggest problem is Octoprint heating failed😥

Are you sure that your power adapters are sufficient?
It doesn't help if you test 5 low power ones :wink:

ok maybe i need to test the power again thanks for help

Finally, I solved the problem ,Before I didn't turn on power from the 3d printer, boot from Respberry pi4 directly.Now I turn the printer power on,everything just fine.Thanks everyone!

1 Like

You can put some tape over the 5V pin of your usb connector.
Then your printer can't power from your pi and this shouldn't happen again even if you power on your pi first.

(pin 1 is 5V)


Thanks for your information!

1 Like