Raspberry Pi Cam V2.1 not working on OctoP V0.17


I have a Raspberry V3B+ v1.3 with OctiPi V0.17 and a Raspberry Pi Cam V2.1 (with 3 flat ribbon cables to be sure the cable is not faulty)
Fresh install (actually 2 times after these problems).
I am working with Windows 10 (Bonjour is installed)

OctiPrint is working good, I can connect easy to it through the IP adress.

I just can't get the cam to work in OctoPrint. I can connect to OctoPrint easily via the IP adress in Chrome.
I tried the octipi.local:8080 page and see if I could see a picture on the mjpg streamer test page
This failed, nothing to see.

In Putty (SSH) I have also enabled the connection to the camera in the raspi-config menu.

I have tried within Putty (SSH) to see if the localhost:8080 was returning something, see below:

pi@octopi:~ $ curl -v http://localhost:8080/

  • Expire in 0 ms for 6 (transfer 0x1a80880)
  • lost of these more
  • Trying ::1...
  • Expire in 149998 ms for 3 (transfer 0x1a80880)
  • Expire in 200 ms for 4 (transfer 0x1a80880)
  • Connected to localhost (::1) port 8080 (#0)

GET / HTTP/1.1
Host: localhost:8080
User-Agent: curl/7.64.0
Accept: /

It seems there is something working, I don't know really?

I have also tried the following:

pi@octopi:~ $ raspistill -o cam.jpg
mmal: No data received from sensor. Check all connections, including the Sunny one on the camerboard

I also tried:
Nothing came back in the picture.

I am beginning to expect that my brand new camera is not working and I should get a new one.
Is there any visual way I can see this on the camera ?

Not sure though what this could be, anybody got an idea to assist ?

quick camera checklist:

  • Is the CSI cable inserted the right way? The silvery contacts need to face away from the Ethernet connector!
  • Is the CSI cable fully seated?
  • Did you insert the CSI cable into the Display connector? It needs to be inserted into the CSI connector, which is the one closer to the Ethernet connector.
  • Is the other end of the CSI cable correctly attached to the camera board?
  • Is the camera activated in raspi-config?

Hi, thanks for reply

Checklist answers:

Is the CSI cable inserted the right way ? Yes, the blue part if the ribbon cable is facing the Ethernet connector, silver line parts going to the back facing the HDMI/power connector.

Is the CSI cable fully seated ? Yes, checked it several times, on both sides.

I did not put into the Display connector, I indeed inserted it in the connector right behind the Ethernet connector.

I inserted the CSI cable in the slot with the blue side facing away from the printboard and the silver lines to the camera lens.

I activated indeed the camera as shown in the linked page.

I have now reinstalled OctiPi again on a SD card through Etcher with Octi V0.17 image of 2.8GB
Is this boot section supposed to be so small ? I get boot section of about 250MB, not sure if there is anymore data written on the SD card ? I got no errors with Validation in Etcher. Probably should be good.

I tried it again following that link, last thing on that page I tried also, got back:

pi@octopi:~ $ sudo raspistill -o myimg.jpg
[sudo] password for pi:
Camera control callback cmd=0x4f525245mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

I have a feeling this camera is dead on arrival. I am not sure, could be something else ?

Ok, it just got weirder..I found an old Logitech webcam and connected it to the PI through USB..guess what? It worked...
I have been pulling my hair all day not getting it to work and now a old webcam works right away.
Sigh...I want this Pi cam to work.

Maybe it's a power issue.
Try it without any usb devices connected

On my new Raspberry Pi V4+ with the latest OctoPi Image (installed everything today) and a Pi Cam V2.1 the camera works out of the box. I just had to do some adjustments to the camera solution in the octopi.txt file

1 Like

The OPI default camera is set to 16/1, the Picam uses 4/3 ratio.

It is in OPi as a camera setting, click on the wrench, look for camera settings.