Raspberry Pi Cam V2 Not Showing Up

Camera model

Raspberry Pi Camera V2

What is the problem?

Octopi isn't showing the camera at all, no matter what I do.

What did you already try to solve it?

I have tried 3 different Raspi Cam V2 modules, on two different Raspberry Pis (one 3, one 4) running Octopi. I've reseated the cables multiple times. Tried multiple different ribbon cables (including the ones that came with the cameras). Toggled camera support on and off multiple times. Rebooted what feels like 2700 times. Checked, double checked, triple checked that I'm connecting to the camera port, and inserting the cable the correct way (blue side facing the USB/Ethernet edge, contacts facing toward the status LEDs). No matter what I do, none of these are detected. Considering I've eliminated the other variables, it seems like the problem is with Octopi itself.

pi@ender3:~ $ sudo vcgencmd get_camera
supported=1 detected=0

This is always what I get.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

Starting up webcamDaemon...

--- Configuration: ----------------------------
cfg_file:      /boot/octopi.txt
camera:        auto
usb options:   -r 640x480 -f 10
raspi options: -fps 10
http options:  -w ./www-octopi -n --listen

Explicitly USB device:

Found video devices:
config file='/boot/octopi.txt':USB device was not set in options, start MJPG-streamer with the first found video device: /dev/video10
/root/bin/webcamd: line 184: printf: 0x: invalid hex number
/root/bin/webcamd: line 184: printf: 0x: invalid hex number
<13>Apr 15 19:24:30 root: Starting USB webcam
Checking for VL805 (Raspberry Pi 4)...
  - It seems that you don't have VL805 (Raspberry Pi 4).
    There should be no problems with USB (a.k.a. select() timeout)
Running ./mjpg_streamer -o output_http.so -w ./www-octopi -n --listen -i input_uvc.so -r 640x480 -f 10 -d /dev/video10
MJPG Streamer Version: git rev: 5554f42c352ecfa7edaec6fc51e507afce605a34
 i: Using V4L2 device.: /dev/video10
 i: Desired Resolution: 640 x 480
 i: Frames Per Second.: 10
 i: Format............: JPEG
 i: TV-Norm...........: DEFAULT
Error opening device /dev/video10: video capture not supported.
Init v4L2 failed !! exit fatal
 i: init_VideoIn failed
Done bring up all configured video device


Additional information about your setup (OctoPrint version, OctoPi version, ...)

Raspberry Pi 4 B
Raspberry Pi 3 B+

OctoPrint: 1.5.3
OctoPi: 0.18.0

:man_facepalming: This has been solved with help from people in Discord. If anyone else encounters this issue, there's a second ribbon cable connecting the image sensor to the board. It's very tiny and it pops off if you so much as look at it wrong.

I wonder if applying a bit of hot glue to hold it in place might be a good idea or not?

Would likely depend on the enclosure, in my case, the enclosure I'm using is quite a snug fit, I don't think there would be room: Ender 3 Pi Cam Boom w/ Swivel/Tilt by j0mb13 - Thingiverse