Raspberry Pi Camera 3 problem

What is the problem?

Rapsberry pi camera 3 doesnt work. Octoprint show a message "webcam stream not loaded. "

What did you already try to solve it?

I tried this instructions (Pi Camera V3/IMX Chipset Based Cameras Not Working - #137 by Venda ) whitch works to my colleague with same hardware ( Raspberry Pi Camera 3 + Raspberry Pi 4 Model B - 8GB RAM) and basic start software instaled from Pi imager. I tested a cam on rapsberry pi os 32bit and it showed a picture corectly. Hardware conections are checked. Octoprint is running normaly only problems with camera.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20230501184714.zip (13.3 KB)

Additional information about your setup

OctoPrint version : 1.8.7
OctoPi version : 1.0.0
sudo updates did by ssh conection from official windows 10
for editing txt files i used notepad ++ (windows 10)

Thank you for your help.

The camera support in OctoPi / OctoPrint is currently in transition. I'd suggest that you download, flash, and install the image from this topic.

While this may require a future reinstall of a newer image, the underlying camera code is much better. There are enough of us running this image that help is available should you need it.

To clarify as well, the Pi cam V3 not working on the current images is expected - it's definitely not supported. The image linked adds support.

Hello Morgan,
thank you for your feedback. I am new there.. and do i need downloand all files or only first zip file and flash sd cart by Etcher?
Uploading: image.png...

Download the image linked at the beginning of the linked topic. Flash it to a microSD card using your favorite imager (I suggest the Raspberry Pi Imager because you can set the hostname, username (use "pi"), password, WiFi credentials, locale, etc. while flashing the microSD card).

Insert the freshly flashed microSD card in your Raspberry Pi 4B and power up. After a couple of minutes you should be able connect with a browser, do the first time setup for OctoPrint, and the camera should just work. If not, let us know.

Yes! it works. Thank you so much for help.

The cam has around 10 seconds latency is it normal?

10s latency is for me better than no cam, but i asked only it if it ok.

I have an RPi 4B, 4GB with the RPi camera V3 (i.e. almost the same hardware as you have). Using the 20230328122604 image I have no perceptible lag, certainly not 10s.

http://rpi4b/webcam/snapshot produces a 1920x1056x24 jpeg image.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.