Raspberry Pi camera module 3 not working

Camera model

Raspberry Pi module 3

What is the problem?

When I load a clean install Bullseye only OS, the camera works. But when I load a clean install Octoprint OS (with new camera stack), the camera is not detected.

What did you already try to solve it?

Tried different OS versions. Tried to install Octoprint manually. Ran all updates, upgrades, and even a dist-upgrade.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20231116145222.zip (21.1 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Raspberry Pi3B with Camera module 3

We really need the Systeminfo Bundle to provide any meaningful assistance.

Sorry about that... Just added the bundle.

It looks like the camera is being detected and streamed OK from the server's perspective, there's no issues there from the looks of it.

Do you see any sort of errors when you view the camera in the UI? What stream URL is configured there?

It says that the webcam stream is not available.

But I borrowed a uSD card from a friend with the same camera module (only difference is that he uses a Pi4), and that works fine on my Pi, so I just made a copy of his card and will use this for now.

I am having the same issue with my Pi4 and camera module 3. I've checked all the connections but don't really know what to look for in the Systeminfo bundle.
Any help would be appreciated.

octoprint-systeminfo-20231117151559.zip (3.0 MB)

Edit: I have also tried my camara module 2 and a different cable. the 2 worked on a different cable and the 3 did not on that same cable. Is there a way to do a diagnostic check on a camera?

You will need to flash the new camera stack image for the v3 picam.

After having a working version from my friends Pi4, I again tried to make my own from scratch.
Downloaded the latest version of OctoPi through the Raspberry Imager tool using the "new camera stack" image. Immediately after first startup of the Pi, I did the "update -y" and so on...
The camera is now not detected in the terminal when I use the "cameralib" command, but via the web interface OctoPrint sees the camera without any problem.
Not sure why it works now, or what happened the last (7) tries, but now it seems to be working also on my own install.