Raspberry Pi Camera Module v3 troubleshooting on new camera stack

Camera model

Raspberry Pi Camera Module v3

What is the problem?

Camera image is not visible. Visiting http://octopi.local/webcam/stream returns a server error. The device is connected. I verified this by running libcamera-hello --list-cameras from the CLI.

Any troubleshooting tips would be appreciated. Thanks!

What did you already try to solve it?

  1. Verify device is connected via cli:
pi@octopi:~ $ libcamera-hello --list-cameras
Available cameras
0 : imx708 [4608x2592] (/base/soc/i2c0mux/i2c@1/imx708@1a)
    Modes: 'SRGGB10_CSI2P' : 1536x864 [30.00 fps - (0, 0)/0x0 crop]
                             2304x1296 [30.00 fps - (0, 0)/0x0 crop]
                             4608x2592 [30.00 fps - (0, 0)/0x0 crop]
  1. Stream test from OctoPrint Settings fails.
  2. Reinstall OctoPi + OctoPrint via Raspberry Pi Imager

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo.zip (18.7 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint version : 1.9.3
OctoPi version : 1.0.0
Printer : LulzBot Taz 6
Raspberry Pi 3

The 'server error' message from camera-streamer is an upstream issue that we're waiting on being resolved. Not quite sure what's causing it or what needs to change just yet. It seemed to be related to not opening the stream within a certain time of the Pi booting, but not sure.

Usually, if you restart the service on the command line (sudo camera-streamer-control restart on the new stack) it comes back online.

Until it is patched upstream, there is no other resolution. This is also why the new stack is not the default yet - although I appreciate it's your only option for the V3 camera.

@ Charlie_Powell Just as a FYI, I have experienced the same error (Server Error) when browsing to http://octopi.local/webcam/stream (including all variants - :8080, using IP address, etc.) and I am using a "no-name" camera module that used to work on the old camera stack. When I run the libcamera-hello --list-cameras from the CLI I get the following:

sudo libcamera-hello --list-cameras
[sudo] password for pi:
Available cameras
0 : ov5647 [2592x1944] (/base/soc/i2c0mux/i2c@1/ov5647@36)
    Modes: 'SGBRG10_CSI2P' : 640x480 [30.00 fps - (0, 0)/0x0 crop]
                             1296x972 [30.00 fps - (0, 0)/0x0 crop]
                             1920x1080 [30.00 fps - (0, 0)/0x0 crop]
                             2592x1944 [30.00 fps - (0, 0)/0x0 crop]

I hope whatever you figure out for the Rasberry Pi camera module v3 also works for my camera :slight_smile:

OctoPrint version : 1.9.3
OctoPi version : 1.0.0
Printer : Ender 3
Raspberry Pi 3B+

Does restarting the camera stack with the command I gave work?

@ Charlie_Powell - I ran the command as requested

pi@octopi:~ $ sudo camera-streamer-control restart
[sudo] password for pi:
Running restart for camera-streamer-libcamera.service...
... done.
Running restart for camera-streamer-usb-default.path...
... done.

and it didn't seem to do anything! I refreshed the GUI in the browser, then checking the OctoPrint Command & Control tab, I still get a spinning wheel as indicated in the image.

Hey all
I have a v1.3 camera. After trying all sorts of things, this seemed to work.

Edit the config file:
sudo nano /boot/config.txt

I then added the following line at the bottom of the file:

Save (control + O) & exit (control + X)

sudo reboot

The camera red led stays on & the live stream finally works in Octoprint.
I do have legacy camera turn on via Raspi-config.

Hope this helps someone.

I tried adding the camera=auto into the /boot/config.txt file but that didn't seem to make a difference for me. Thanks for the info. I'll give almost anything a crack to get this working. Cheers.

@Charlie_Powell - I can confirm running sudo camera-streamer-control restart did not resolve the issue.

Adding camera=auto to /boot/config/txt also did not resolve the issue. Thanks for the suggestions!

Running sudo camera-streamer-control restart worked for me. I had a working camera and it stopped working for some reason. this has restarted it

1 Like

I had a similar issue that got far worst after adding my second and third camera.

The "Server errors" would appear, and the error is somewhat random. e.g. If I have three cameras installed or four with a RaspiCam the errant server would move to a different stream or to more than one stream each time I rebooted the Pi4 I am using.

I temporarily got around it by lowering the streaming resolution as much as possible, e.g. 320x240 @ 15 FPS. All streams became viewable with no "server error" after doing that.

Then I worked backward increasing the resolution one stream at a time until the error re-appeared, and backed down again.

There seems to be some delay when switching streams from the client side.

1 Like

I can confirm that lowering the resolution to 320x240 cleared up the server error problem for me as well.