Raspberry Pi camera stop live streaming

#1

What is the problem?
OctoPrint lost it's RPi camera connection out of the blue. It worked just fine for months now, but after a reset plugin update it completely lost the live streaming feed.
What did you already try to solve it?
Going into the Webcam & Timelapse settings the live stream link does not show anything while the image snapshot link works perfectly without any issues. I did try to reboot OctoPi a couple of times with no success unfortunately...
Additional information about your setup
Note that I had it working on these versions before it stopped providing the live stream!

OctoPrint version - 1.3.11rc3

OctoPi version - 0.16.0 running on a RPi 3B+ with an RPi Camera connected to it via CSI cable

printer - Original Prusa MK3S-MMU2S

firmware - 3.7.1

terminal tab sample (it is repeating itself):
Send: M105Recv: ok T:22.9 /0.0 B:22.8 /0.0 T0:22.9 /0.0 @:0 B@:0 P:24.0 A:30.8 Send: M105Recv: ok T:22.7 /0.0 B:22.7 /0.0 T0:22.7 /0.0 @:0 B@:0 P:24.0 A:31.3 Send: M105Recv: ok T:22.7 /0.0 B:22.7 /0.0 T0:22.7 /0.0 @:0 B@:0 P:24.0 A:31.4 Send: M105Recv: ok T:22.7 /0.0 B:22.9 /0.0 T0:22.7 /0.0 @:0 B@:0 P:24.0 A:31.1 Send: M105Recv: ok T:22.7 /0.0 B:22.8 /0.0 T0:22.7 /0.0 @:0 B@:0 P:23.9 A:31.1 Send: M105Recv: ok T:22.6 /0.0 B:22.7 /0.0 T0:22.6 /0.0 @:0 B@:0 P:24.1 A:31.4 Send: M105Recv: ok T:22.5 /0.0 B:22.6 /0.0 T0:22.5 /0.0 @:0 B@:0 P:24.0 A:31.1 Send: M105Recv: ok T:22.5 /0.0 B:22.5 /0.0 T0:22.5 /0.0 @:0 B@:0 P:24.1 A:31.3

octoprint.log is attached here: octoprint.log (611.0 KB)

Any ideas are greatly appreciated!!!
Thank you.

#2

Seems like this is resolved.
Apparently (if someone else encounters this issue) an alpha version of OctoPrint Anywhere broke OctoPrint 1.3.11, which then in turn severed the live stream functionality of OctoPrint.
After updating to the latest Alpha version with the official release of 1.3.11 the problem is solved.

1 Like