Raspberry Pi compatible camera too zoomed in

Camera model
SainSmart Infrared Night Vision Surveillance Camera + 2 Infrared Light for Raspberry Pi Arduino, 5 MP Omnivision 5647 Camera Module

What is the problem?
The issue I am having is that the camera is too zoomed in. The camera is about 6 inches from the object being recorded.

What did you already try to solve it?

I have edited the /boot/octopi.txt to set the resolution but anything above the 640 x 480 just zooms in further. I am planning to move the camera further away but is this the only option?

Additional information about your setup (OctoPrint version, OctoPi version, ...)
I am also using Octolapse and have enabled the custom configuration for the camera but there is nothing in there to zoom out further. I have the image stabilization off.

I have read through the forums but can't seem to figure out what else to do next.

And here is what I am seeing.

It should be the V1 cam so this docs should help you
https://picamera.readthedocs.io/en/release-1.12/fov.html

here you can see when an how much the image is cropped

# Resolution Aspect Ratio Framerates Video Image FoV Binning
1 1920x1080 16:9 1-30fps x Partial None
2 2592x1944 4:3 1-15fps x x Full None
3 2592x1944 4:3 0.1666-1fps x x Full None
4 1296x972 4:3 1-42fps x Full 2x2
5 1296x730 16:9 1-49fps x Full 2x2
6 640x480 4:3 42.1-60fps x Full 4x4
7 640x480 4:3 60.1-90fps x Full 4x4
1 Like

Thank you. I have read through this as well as a thread that refered to it. I have the following in my octopi.txt

I am not sure how to enabled the 640 x 480 binned option.

image

it's a raspicam, not usb.

edit the camera_raspi_options line instead :slight_smile:
if it still doesn't work change camera="auto" to camera="raspi"

also make sure that no plugin is interfering with your cam settings - try safe mode if you aren't sure about that.

1 Like

Effect of troubleshooting at 2 am lol

Ok so changing to camera_raspi_options didn't change the resoultion

camera="auto" to camera="raspi"makes the service go down.

this setting works for me

make sure you put a # at the beginning of the lines you don't need

ok so looks like the options are being applied. I got the raspi options to work becuase I disabled the custom controls for octolapse and the webcam image stutters more when i up the resolution. however, the zoom is not changing. so FOV is not changing at all.

I don't know this cam - can you maybe rotate the lens or something to zoom out?

So much for saving $10 and not going with the official...:frowning: the lens rotation only focuses the lens....does not change the zoom.

you could print a longer arm for the cam so it's further away :man_shrugging:

Yeah, I am actually in the middle of printing this. Spent a lot of time last night figuring it out and reached nowhere. So longer arm it is.....Did learn a few things thoug. Thank you for all the help!

1 Like