Raspberry Pi Imager problems

New here so sorry if this is in the wrong category.

Using the latest version of Raspberry Pi Imager I tried to install Octo on a 32GB Micro-SD (from a Linux system). Used ctrl-shift-x to enter SSID, pwd and region and it wrote just fine until the end where it complained that it can't write the startup file. Naturally it didn't boot into WLAN and also didn't use the changed SSH passwd.
Not that it stopped me as I edited the octopi-wpa-supplicant file and made the pwd change after logging in via SSH but it may be a bit of a problem for beginners.
What I would also suggest to add in the instructions on the download page is to recommend running sudo apt update and sudo apt upgrade as the image is naturally a bit outdated (had 160 upgrades to install)

System is running great and the best thing I did to my 3D printer!

I can't see any existing issues about it on the RPi Imager GitHub page. It might be worth reporting your problem with failing to write the firstrun.sh script (I think that's what it's called). You are right that it definitely would confuse some people.

Doesn't using ctrl-shift-x to change the WiFi parameters get overridden in OctoPi by the octopi-wpa-supplicant.txt file?

OctoPi also enables SSH by default so that setting isn't needed in the ctrl-shift-x menus. Changing the host name and setting locale are the only things that I would change. You can set the hostname by creating a octopi-hostname.txt file in /boot as well.

ctrl-shift-x is recommended on the octoprint download page and naturally one uses it as a start. Changing the SSH password from there and entering the WLAN parameters is easier for a beginner too. But it just didn't work. As I am running Linux since 1998 it wasn't a game stopper but I am sure that many will have problems with it if they aren't familiar with Linux.

Using ctrl-shift-x and setting the WiFi parameters will end up in the octopi-wpa-supplicant.txt file when you first boot the image. RPi imager creates a firstrun.sh script that puts them in there when you boot it.

There's been a lot less questions about connecting to WiFi since we switched the main install tutorial on OctoPrint.org - Download & Setup OctoPrint to use that, since it can auto fill (no typos) and Linux Vs windows line endings are not an issue etc.

Where does the RPi imager create the firstrun.sh file?

In the root of the boot partition.

So I just ran the RPi imager (on Windows 10), used the ctrl-shift-x menu, and wrote an SD card.

After removing and inserting the SD card (on Windows 10), I examined the /boot partition. There is no firstrun.sh script. The octopi-wpa-supplicant.txt isn't changed either.

The only file written this year :slightly_smiling_face: was cmdline.txt and it does contain systemd.run=/boot/firstrun.sh.

Presumably you did enter some WiFi credentials, if that's what you are looking for? If it doesn't create the script it usually throws an error as the OP was talking about.

That's expected - as I said before it only adds them to octopi-wpa-supplicant.txt after boot.

I can't tell if you're trying to say the process doesn't work, or just trying to see how it works yourself - the RPi imager works for everyone else just fine.

Well excuse me.

Working fine is probably a very generous description. RP Imager works fine as long as one doesn't use ctrl-shift-x to enter some data. At least on 3 different Linux machines with different distros.
With OctoPrint it just throws the error message and doesn't write the firstrun.sh file. With Raspberry Pi OS after entering WiFi credentials, SSH key aso with ctrl-shift-x it pops up a warning "Verifying write failed. Contents of SD card is different from what was written to it" and doesn't finish. Card requires a re-formating to be usable again.

In my world that would be considered to be broken....... The only "good news" is that it is less broken with OctoPrint than with RP-OS.

Still not working and i'm one of those less experienced guys so i lost 2 hours trying to solve this, that sd card is not accessible in Windows, i don't understand how people access that in Windows. Anyways had to plug the ethernet cable, access with filezilla, no permission to edit that file, of course search how to get permission cause i'm a little kid and i need a stupid permission, load putty, sudo whatever -777 -664 -775 still no permission, even tried the nightly build hoping that works but no, i'm done with this pos for now

@Adrian_Belzebut this sounds like you need to open up your own support issue by creating a new post in the #support section, making sure to include all the requested information. From your admittedly very vague problem description it doesn't sound this is the same issue.

It was the same problem, the fact that it got an error upon completion from raspberry pi imager and the settings were not saved.
Now it's a different problem indeed, as i've managed to access the sd card and change ssid and it still won't connect to wifi.

Did you use an editor which doesn't generate a screwed up file format? Did you also set the country correctly? Did you leave the quotation marks around SSID and password? Did you check whether it is shown in your WLAN router list or not?
If it is shown in the list, did you try connecting with the IP address?

You sadly failed to point this out in your vague description, so how were we supposed to know? All you told us was "Same problem" and then proceeded to talk about ethernet, permission changes, not seeing a partition in windows at all and other unrelated issues. If you want assistance you need to precisely state what problem you are facing, not just chime in a thread and then proceed to take it into a completely different direction.

I also have you know that classifying something as a "POS" is understandable when you are frustrated, but keep in mind there are people here who want to help you, myself included, and treating their hard work like that is not going to make it more likely to receive assistance.

Apologies for that, madame, i was a bit tilted, i appreciate your prompt response.

So i edited the file with notepad++, I modified WPA/WPA2 ssid and pass leaving quotation marks, country initials. Put the sd in a pi3 and a pi4, tried both the 2.4Ghz and the 5Ghz networks, ssid and pass is 100% correct, the pi is close to the router.

One thing to mention is that i already have another octopi on the network that i set up a long time ago. I assumed that would make no difference and the dhcp server would assign a different ip to the new one but i'm not so sure now.

Multiple systems with the same hostname will confuse the DHCP server. Add /boot/octopi-hostname.txt with a different name than octopi. The system running the DHCP server may need to be rebooted to unconfuse it.