Raspberry Pi Internet Connection Troubles

What is the problem?

Hello! I am trying to install the OctoPi/Klipper combo available in the Raspberry Pi Imager. I don't want to install Klipper separately because I don't want to mess around with SSH-ing. I have a Raspberry Pi 4B, my computer is Windows 10. My Pi isn't showing on the router, and I can't access it under raspberrypi.local. The little green light on the Pi blinks 8 times when powered up. If someone would please help me fix this, that would be great! I also would prefer not to download any software to fix it, if possible. Thank you for your time and I look forward to your response!

What did you already try to solve it?

  • Made sure the internet settings were right
  • Changed the Host Name to raspberrypi
  • Tried different SD Cards
  • Tried searching IP Addresses that were labeled "Unknown Device" (Question: Will a Raspberry Pi always be labeled "Raspberry" something in the router and will the single digit number always be a '0'?)

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Note: I have run OctoPrint on this Pi but I deleted it to upgrade to Klipper. After I set up OctoPrint for the first time I did have trouble logging in via "octopi.local". I got a "This Site Can't Be Reached" message. It took a few tries, but I did end up getting it to work by re-opening the tab repeatedly.

Are you sure it's not 7 times?
7 times means something is wrong with the image on the sdcard and it can't boot

8 times means SDRAM failure

Don't count the long flashes - only the short flashes are the error code

1 Like

You also can try by connecting a HDMI TV/monitor to the Pi to see what going on during boot.

Thanks for the heads up on the flashes! The short flashes blink 3 times.

Whoops! Now they're flashing 4 times!

And on the screen?

I still can't reach my Pi. What screen? (Sorry, this is my first Raspberry Pi experience!)

That one. I thought you did.

Oh, sorry! I will try that and let you know!

1 Like

Hello again! I found out that do not have a HDMI cord the right size to connect to anything. Is there any other things I could try? Thanks!

Buying a proper HDMI cable would be a good investment. For an RPi 4B, use https://www.amazon.com/gp/product/B06WWQ7KLV.

Alternatively, in addition to the cable, you could purchase either https://www.amazon.com/gp/product/B07VNX4ZWY or https://www.amazon.com/dp/B087RC8B79.

I also have a mini-keyboard, https://www.amazon.com/gp/product/B01IQL2VCE

I have found the small monitor and the mini-keyboard very useful for troubleshooting a variety of SBC projects.

Thanks! I will consider that.

Hello Again! I bought an HDMI cord as suggested by b-morgan, but I can't access it. Could someone help me with connecting it?

Hello Again! Thanks to all who responded in this topic! Me and a friend determined that there was an issue with the files on the sd drive. I ended up just installing Octoprint by itself, and I'll have to install Klipper separately. Thanks again!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.