Raspberry pi is full in /dev/root 100%

My Raspberry pi seems to be full and i can't upload new .gcode files

I tried to see how much space is remaining by running the df -h code in ssh mode.

Its also reporting the same problem in octoprint UI,

The problem is that am not so much familiar with Linux and therefore don't know the proper way to clear the logs. I would like to get help on that please?

How big is the SD you're using?

fdisk -l

well, when i ran the command, i got the following output

So it is indeed a 4GB SD. You can look for excessively large files via

sudo ncdu -x -r /

If ncdu is not installed you can install via the cmd below. You might want to delete some gcode files first though.

sudo apt install ncdu

1 Like

So, where is the disk space used up?
sudo du / -h --max-depth=2 --exclude=/proc --exclude=/dev --exclude=/sys
will give you a list of directories and their respective sizes.

On my systems (with a more or less regular apt-get update && apt-get upgrade) one place to look is /var/cache with hundreds of MB of packages in it.

sudo apt-get clean will free that space (deleting older versions you probably won't need ever again)

Another place is /var/log
ls -lSr /var/log will list all the files there from smalles to biggest.

sudo rm /var/log/*gz will remove all archived old logfiles.

glad I saw this. my octolapse directory was jammed. Removed all mp4 and it snapped back to life. Now to do some maintenance. Thanks for having the same problem as me.

One reason I made the Timelapse Purger plugin....

1 Like