Raspberry Pi Zero 2 WiFi disconnects

I'm trying to confirm if the Zero 2 has less WiFi 'capability' than the old Zero W as I'm struggling with intermittent disconnection issues that I believe is related to RF interference.

Recently switched from a Raspberry Pi Zero W to a Zero 2 as an OctoPrint host on my Prusa i3 MK3S+ (connected via GPIO pins). While the Zero wasn't supported; it mostly worked for monitoring without any real issue and the wireless connection was rock-solid. (No connection problems in more than a year.) I upgraded to the Zero 2 when it came out so that I felt comfortable running some plugins, etc, rather than just using it for monitoring.

Attempts to Solve
I have already turned off power management on the Zero 2 (which apparently is enabled by default) and caused me some early issues. While my printer (with the Zero 2) was in my kitchen (with good connectivity to the AP), the connection was up for several days. When I moved it back into the enclosure in the garage, I am able to connect during work-days in the morning, but by noon. I had a ping running for a while (checking every 60s) and it seems like OctoPrint was connected sporadically, leading me to believe wireless interference is the problem. However, again, for over a year I didn't have the same problems with a Zero W.

Can anyone confirm this is a problem or give me some other suggestions for fixing this (other than the obvious: move the printer, add an AP to my garage, or use a different RPi via ethernet). If there is any other info that might be useful, please let me know. Thanks very much.

I can only report that I have a similar if not identical problem. I have the same printer, raspberry and octoprint. I had no issue for 6 months. I moved the printer further away in the house tonight. Everything was fine for few hours, then suddenly it disconnected while I was uploading a file to octoprint. I had a print going at the same time. The raspberry pi zero 2 has not connected back so far. The print is still going. I suppose the rasbberry pi is still running, but not reconnecting actively. Or maybe when the signal is weaker it uses more power for the antenna and maybe overheat or something like that?

I am still having this problem with no resolution. However, to add to the information, I watched dmesg until it "fell off" the network today, and received the following messages (the first line suddenly repeated hundreds of times and then the connection froze after the second message).

[Thu Nov  3 14:47:06 2022] brcmfmac: brcmf_sdio_htclk: HT Avail request error: -110
[Thu Nov  3 15:45:57 2022] brcmfmac: brcmf_sdio_isr: failed backplane access

My searches indicate a similar problem happened to RPi4Bs but was apparently resolved with a patch over a year ago. I would welcome any suggestion for information I should gather or how I can further troubleshoot this problem?

Is your OS up to date with sudo apt update and sudo apt upgrade run?

Yes, I’ve done both as well as a dist-upgrade (to see if that would fix it). Last one I did was yesterday before watching the logs.

Yesterday I did a clean install of Ubuntu 22.04.1 server (and installed octoprint manually via pip). The Zero 2 W is having the same issue. As a result, I suspect it isn't a octoprint problem but a RPi Zero 2 W problem. I'm not sure where to go from here to seek a solution.

I can confirm that I have the same problem
It was working fine for few months till recently
My pi zero 2 w suddenly not being connected to wifi
But printing is still going on
And when it finishes
I receive an email from obico plugin that job is done and video is ready
I turn off and on the pi and the whole video is there
I think it's overheating

Hm that means it's still connected to the WiFi
Did you try to ping the pi when you can't reach the webui anymore?

No i did not.
I'll try it next time and update here
Btw how to ping
From windows cmd?

Type in ping followed by octopi.local / octopi / the pis ip

For example
ping octopi.local

Again went offline but after a print finished.
Tried pinging
I got
Ping request count not find host

I took the zero 2 out months ago but I can confirm that it loses connection entirely confirmed both via ping and my pfsense router.

I actually came back to this today because I wanted to see if anything had been fixed yet—my prusa has been sitting unloved for a long while because I hate running sdcards to it and I have a social sv06 running Klipper.