Raspberry wont boot while connected to 3d printer

What is the problem?

Raspberry Pi wont boot while connected to 3d printer (Pi powers on but no green light), remove usb cable and Pi boots correct(Green light on pi flashes as soon as cable is removed). Plug USB cable back in after boot everything is fine.

I know this isn't octoprint problem, but I'm hoping someone here might have experienced this before

What did you already try to solve it?

Nothing as I'm lost what to do

Have you tried running in safe mode?

N/A

Did running in safe mode solve the problem?

N/A

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

SKR3, Pi4, anycubic chiron

My guess is that either the pi tries to boot from the printers sd card or it's a power related issue.

If you have an sd card inserted, try again after you removed it.

Also check if there is a jumper on the VUSB pins - remove it if it's there.

1 Like

Tape the 5v pin on the USB connector..

1 Like

I did that already thanks. Wont work either way

That jumper does exactly that..

Don't have that USB jumper connected or an SDCARD inserted. Thanks for the suggestions

Already tried a different USB cable?

Yep even tried a different Pi, so must be something to do with the printer