Raspi Cam isn't working

Camera model
RaspiCam with wide angle at the CSI port image
What is the problem?
No webcam stream.

Error message:
Webcamstream nicht geladen

Es liegt evtl. eine Fehlkonfiguration vor oder es werden Logindaten benötigt. Du kannst die URL des Streams unter "Einstellungen" > "Webcam & Zeitraffer" > "Webcam" > "Stream-URL" ändern. Falls du keine Webcam hast kannst du Webcam-Unterstützung dort auch deaktivieren.

Aktuell konfigurierte Stream-URL: /webcam/?action=stream

What did you already try to solve it?
reinstalled mjpgstreamer completely, sudo modprobe bcm2835-v4l2 gives no error back but there is no /video0 only video10, 11, 12, 13, 14
tried a different raspi cam of the same type
Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)
see Attachment
Additional information about your setup (OctoPrint version, OctoPi version, ...)
octoprint-systeminfo-20220222090700.zip (165.2 KB)

All help is appreciated!

hi :slight_smile:

here my raspicam checklist

  • Is the CSI cable inserted the right way? The silvery contacts need to face away from the Ethernet connector!
  • Is the CSI cable fully seated?
  • Did you insert the CSI cable into the Display connector? It needs to be inserted into the CSI connector, which is the one closer to the Ethernet connector.
  • Is the other end of the CSI cable correctly attached to the camera board?
  • Is the camera module itself correctly connected to the camera board (see picture below)?


I guess it is likely more a software / paramete issue.

No video0 device means it isn't detected by v4l2.

For other users this cam model works as drop in replacement / out of the box so I was rather looking a the hardware side.

Just to be sure - you're using an OctoPi image, right?

Yes, downloaded two weeks ago.

As the camera worked with other raspbian installation it should as well with the octopi image.

I again tried to enable the camera via raspi-config. With raspistill it can take pictures. So the hardware is working.

And now there is a /dev/video0. I don't know, why it wasn't before. I enabled the camera in raspi-config several times... But still no stream.

In webcamd.log this is the last entry:

Starting up webcamDaemon...

--- Configuration: ----------------------------
cfg_file:      /boot/octopi.txt
camera:        raspi
usb options:   -r 640x480 -f 10
raspi options: -x 1920 -y 1080 -fps 30
http options:  -w ./www 

Explicitly USB device: 

Found video devices:
config file='/boot/octopi.txt':Start MJPG-streamer with video device: raspi
<13>Feb 22 15:11:59 root: Starting Raspberry Pi camera
Checking for VL805 (Raspberry Pi 4)...
  - It seems that you don't have VL805 (Raspberry Pi 4).
    There should be no problems with USB (a.k.a. select() timeout)
Running ./mjpg_streamer -o output_http.so -w ./www  -i input_raspicam.so -x 1920 -y 1080 -fps 30
/root/bin/webcamd: line 151: ./mjpg_streamer: No such file or directory

/root/bin/webcamd: line 151: ./mjpg_streamer: No such file or directory Maybe this is a hint?

Btw I'm using a Raspi 3B.


Now I found out, that ffmpeg was missing so I installed. But the mjpg-streamer is still not working. I guess it is missing, too. Can somebody please tell how to install it?