Raspi-Cam timelapse is always 640x480

octopi

#1

The timelapse for the raspberry pi camera (v2) renders out at 680x480. Regardless of any settings I change in the /boot/octopi.txt file. The settings do take effect, I can rotate and change frame rates of the stream. I've hooked up a usb camera to the pi, and obtained 1080p timelapses right off the bat.

I discovered OctoPrint a couple days ago, and was up and running in no time. But I can't get high quality lapses.

The webcam works perfectly fine with:
camera_usb_options="-r 1920x1080 -f 10"

I've experimented with all sorts of settings for the rpi-cam, for example"
camera_raspi_options="-r 1920x1080 -fps 15 -q 100 -rot 0"
and
camera_raspi_options="-md 3 -fps 10 -rot 0"

I do have to use -rot 0 because for some odd reason, when I adjust the resolution (anything larger than 640x480), the camera zooms in and rotates the screen. Using -rot 0 re-orientates the stream, and the view fits inside the stream window again. I've even tried using different shooting modes for the raspi-cam, like in the second example above, -md 3. I forced it to shoot in 4:3 instead of 16:9, but that didn't help either.

There was one notable test were I didn't rotate it back, and left it zoomed. The timelapse was also zoomed and same orientation (still 640x480).

The webcam is a bit heavy (~40g+), and I would prefer to use the raspi cam (~2g) on my printer bed.

Any suggestions? Is there a little setting I'm missing somewhere?

RPi 3
RPi Camera v2
Additional Webcam: Logitech c920
OctoPrint 1.3.6


#2

I'm using:

camera_raspi_options="-fps 5 -x 1280 -y 720 -quality 100"

and my timelapses are that size.


#3

Thank you for replying.

Interesting. I've tried using -x & -y in testing, but it didn't work at the time. I just tried your line, and it worked splendidly!

Trying to narrow down the root of the issue, I changed -quality back to -q to see if that was the initial problem (it's not, still 720p video, yay!). I'll do a few more tests later.


#4

Hey Spooky, did you find the solution to have timelapse in 1080P ?


#5

Sadly, no. I got it to work once for a single frame. I've tried two different Model 3 B's, V2 cameras, and C10 SD cards (two complete set's of components). I've spent hours running dozens of trials to no avail. So I'm stumped. If anyone has suggestions, I'm all ears. If it helps narrow down the problem, whenever I increase the resolution the camera zooms inward. So that single frame of 1080P had a quite narrow FOV.

For those in the future who don't know (like me above), -r _x_ for resolution only works for USB cams (as far as I can tell). But I don't have a source for that. Raspi cam settings can use either -x _ -y _ or (from the raspi cam doc) -w _ -h _ (both work for me). Additional info on changing camera settings here by foosel.

It's certainly possible I'm missing something quite silly. I'll settle with 720P for now, but I'm open to all suggestions if anyone knows what I might be doing wrong.


#6

Dude not sure why this works but its the only thing that got my camera to work !! been searching for 2 days