Raspi camera stopped working after update

Camera model

Raspi camera v2 and v1.3

What is the problem?

I can't get Octoprint to display anything from the camera. I tried both cameras, only got 1 small LED flash from the camera when booting with the 1.3 and then nothing.

What did you already try to solve it?

I tried checking the cables, reseating them, used 2 different camera modules, changing /boot/config.txt and octopi.txt settings. None of it worked. I can still print but I cannot get the camera to work.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20230816153942.zip (1.3 MB)
vcgencmd get_camera returns supported=1 and detected=1

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Raspberry Pi 3b+ running Octoprint 1.9.2 and Octopi 0.18.0. Connected via microusb to the printer.

You said 'after update'. What update did you do?

I believe the update to 1.9.2 and Octopi 0.18.0 were the updates I applied.

I have a working RPi Camera 2 on a RPi 3B using OctoPi 0.18.0 and OctoPrint 1.9.2. My printer is a LulzBot TAZ 6.

vcgencmd get_camera returns supported=1 detected=1 and I haven't messed with /boot/config.txt or /boot/octopi.txt. I have attached my files for your convenience.

Temp.zip (2.5 KB)

With those /boot files, here is the webcamd.log:

webcamd.log.1.zip (1022 Bytes)

Hopefully, this information from a working system very similar to yours (I have 3B, you have 3B+ and our printers are probably different) will help you get your camera working.

1 Like

I figured out my issue. I tried 2 different raspberry pis, both 3b+, and discovered my pi camera would not turn on regardless of what power supply, ribbon cable, or versions of the 0.18.0 Octopi I used. I downloaded the latest version of Octopi from the github page (1.0.0) and flashed a new SD Card; guess what, it worked! Camera light would turn on and things seemed to be working. I will update if there is any problems with the recovery process, but I'm hopeful this will be a smooth transition.