Raspi HQ camera stops working, when i switch GPIO pins

Camera model Raspberry HQ Camera

What is the problem?
My Creality CR10 Printer is connected GPIO 22 and the LED Lights on GPIO 27 both with relay to switch.

As soon as i switch on the Printer and/or LED light with the relay on my Raspi GPIO Pins the HQ Camera stops working.
(Everything worked with my old USB Camera, but how can i get the HQ cam working :frowning: - I'm hacking since 3 days now)

What did you already try to solve it?
different GPIO Pins
fresh OCTOprint install - several times
i tried with the OctoRelay plugin
i tried the PSU Control - RPi.GPIO plugin

OctoPrint - Version 0.18.0, running on Raspberry Pi 3 Model B Plus Rev 1.3

OctoPrint The snappy web interface for your 3D printer Version 1.8.1

Please give me some new perspectives/ideas to solve my problem, I am at the end of my ideas and I wanna make some HQ timelapse videos.

thanks Christian

sounds like an undervoltage issue to me

either the relay is drawing too much current or the psu isn't sufficient

I guess you could try to add a capacitor to your circuit - but I don't know which size.
Maybe somebody with more electronics knowledge can help us out here :slight_smile:


this is the Relay I use

and my Raspi is powered by 5,1V & 3,5A

I dont think its an under voltage problem, but if i think about the problem i get, it looks like undervoltage.
I thought the power adatpter that i use is pretty strong?

The links does not work with me.

Keep in mind, that current draws are added.

Can you please share the systeminfo bundle.

You may try to connect the HQ cam via a self powered USB switch to the Pi.

It's connected to the CSI port

1 Like

Systeminfo bundle:

octoprint-systeminfo-20220801124838.zip (35.5 KB)

@Ewald_Ikemann do you mean to try to connect the Camera with this 40USD CSI USB "adapter" converter?

This may be not necessary.
Due to the octoprint.log, there has no undervoltage issue occurred, but this one:

|      throttle_state: '0x80008'

This appears when the Pi gets too hot.

octoprint-systeminfo-20220801133153.zip (49.1 KB)

I cooled it down with my roomfan, raspi has now 40Β°C, but still same problem.....

I went down with the resolution. the camera works for 2 seconds with 640x480 resolution.
with 320x240 it immediately stops again by switching the gpio pin.

OK, i found the problem. I had a "pretty" long (1,3m) flat cable between the HQ camera and the Raspi. I tested now with the 20cm one and it works. puhhh that was a tricky one^^

1 Like