Raspicam Resolution in Octopi 1.0.0

Pi Cam 1.3

Can't set resolution in octopi.txt file

**Tried to add this line: camera_raspi_options="-x 1280 -y 720 -fps 20" **

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

Additional information about your setup (OctoPrint version 1.8.6, OctoPi version 1.0.0
webcamd.log (94.1 KB)
, ...)

While I also have some issues with the webcam, I've was able to set the resolution using camera_usb_options="-r 1280x720 -f 20". In the comments in the file it says that the raspicam is not supported anymore.

I used the camera_raspi_options when I was still on Octopi 0.18.0, and there it worked

Thanks. I believe I tried that line with usb instead of raspi and the camera wouldn't load at all, but I'll try again.

So raspicam is not supported at all? Or just through another module?

The RPi cameras have worked with the v4l/uvc drivers for quite a while, not needing the raspi mode, and in RPi OS bullseye the driver that the raspi mode used is legacy & disabled by default. So you can use either auto/usb setting & get the camera stream, no cameras have stopped being supported. Note that some of the parameters are a bit different (eg. resolution on raspi was -x and -y, whereas with 'usb' it is -r), so you can't just copy & paste into it.