Read-Only users isn't working

What is the problem?
With the new Access Control, Read-Only users cannot be created. This is because every user created is forced to have the User's group associated with the account. This overrides all the settings in Read-Only users.

What did you already try to solve it?
Tried to create a normal user and a read-only user, unchecked the default option for the User's group as well.

Screen shots of the errors. Logs have no information regarding this issue.

Additional information about your setup
Octoprint 1.4.0, OctoPi 0.17.0, Raspberry Pi 4 with Raspbian, Prusa i3 MK3S 3.8.1, Brave browser on Windows 10, also Safari on MacbookPro.

1 Like

I've just come across the same problem too, did you manage to find a resolution?

I have not found a work around yet. I was hoping someone from Octoprint development would chime in.

Create a new Users group with the same permissions as the default (or adjust as desired). Then remove all permissions from the built-in Users group.

This actually fell off my radar. Could you open a ticket about this please so that doesn't happen again? Sounds like I overlooked something.

i just ran into this issue. i am trying to make a guest account but when i log in as the guest, i can control my printer.... that is not good. I can select the only two options that i want them to have which is live video and time lapse video. but they have full control. and i can't check Guest, just change the individual permissions. but that did not work

After tinkering around, i made a new group, gave only UI, Timelapse download, time lapse list, and live view. unchecked default from users. I made a new user with this new group and made sure that only my new group was active. i saved it, and the user group was added to that user even though i did not want that. just thought i would add that info that i tried.

So after a long time of playing with this, and since i do not need multiple users, it's just me sending files, but i want the ability to have others log in and see what i am doing, and one friend of mine to alter files, i will have to give him special permissions on top of the user permission. i had to strip the users permissions down to "file list, GCODE Viewer, Settings Access, Status, Timelapse download, Time Lapse list, Webcam." which allowed me to have guests log in and they can see with out the ability to touch anything or make changes. what i wanted the Guest account to be able to do. just trying to help if others need this function, change to these settings on the Users profile, and if you need others to have different acces you will have to make a new group with the permissions you want them to have and add them to that group. something is bugged forcing this group onto all new users. this, at least for me, is working and seams to be functional for my use.

I have this same issue. Did a-aron every open the ticket? If not, I'll open one with his description from the first post in this thread.

Nope, no one ever opened a proper ticket for that. Myself included because I forgot about it again.


This is my first bug report. I did read the guidelines in GitHub, but I also copied the material that a-aron provided in the first post. Please let me know if I need to add anything (for this bug report or generally for future bug reports).

[Update] The GitHub issue I submitted has been updated because the GitHub bot complained.

1 Like