Reboot required every day

t### What is the problem?

Everyday I need to reboot Octoprint by plugging the power supply in and out before I am able to connect to my printer (Creality Ender-3 V3 SE)

What did you already try to solve it?

I've disabled some plugins, switched cable and tried using another USB port.

Systeminfo Bundle

plugin_pluginmanager_console.log (16.6 KB)
octoprint.log (4.0 MB)

Additional information about your setup

OctoPrint running on Raspberry Pi 4. Version 1.9.3

It looks like your OctoPrint instance is running out of memory. This could be caused by a plugin that has a memory leak. It will be a slightly annoying process, but you will have to disable some plugins, and then watch the memory usage, and then disable some more until you get it back running stable and can locate the plugin with the issue.

Based on the continuous log entries, I might be tempted to disable the 'OctoApp' plugin first.

1 Like

Thank you. I've just disabled the OctoApp plugin. Hope that helps.
I also see entries with Debug (for the webcam) is there an option to disable that?

Well I've tried to connect again today but sadly I've had the same problem.
When this happens I am also not able to login with my credentials. A reboot fixes this.

So after disabling OctoApp from the plugins I still had to do a power cycle.

I use OctoApp and have no memory leak issues. As stated, quickest way to find the culprit is to disable plugins until the issue goes away. You can break it into groups, disable a group of them and see if it goes away. If not, re-enable the entire group and disable the next group. Do this until the problem goes away and then re-enable them one by one from the disabled group.

1 Like

I have not forgotten about this! The last 10 days i've been busy finding the culprit.
I have disabled a bunch of plugins and each day I am checking to see If I can make a succesfull connection. When this works I enable another plugin. So far I have narrowed it down to on of the following the will be the culprit:

  • Camera Settings
  • DisplayLayerProgress
  • FileManager
  • OctoEverywhere
  • Octolapse
  • Preheat Button

OctoEverywhere is another plugin that is "continuously doing something" and might be candidate to cause a memory leak. I doubt the others would. But who knows.

Well still not completely sure what caused it but issue looks resolved.
I've got rid of:

  • Detailed Progress
  • Camera settings
  • PrettyGCode

Found out that SimplyPrint was causing an issue.

1 Like

@AlbertMN would probably want to know that...

Hi there! :slight_smile: Creator of SimplyPrint here. We'd love to take a look at this and get to the bottom of why SimplyPrint may be causing problems for you!

From your logs, I can't really see any problems at first glance - no "exceptions" / errors, not a lot of reconnecting to our servers either, and usually SimplyPrint is quite lightweight, and rarely causes issues like this alone - so perhaps it's a combination of SimplyPrint, and some other plugin.

If you'd like help getting it resolved, and help us get to the bottom of this, please hit us up in our live-chat over at https://simplyprint.io/, in the bottom right corner of the website.

Thanks! And thanks @jneilliii for the tag.