Received Error: "Failed to autodetect serial port, please set it manually." when attempting to connect over ethernet

What is the problem?
I am unable to connect to my already running octopi server via ethernet. Fortunately it seems I've had no problems getting the octoprint server started up on my dorm's network through ethernet since I'm unable to connect via wifi through the several 2-step secured networks. However, when attempting to connect to the server itself, I get "Error: Failed to autodetect serial port, please set it manually."
What did you already try to solve it?
First off, I tried connecting the server via wifi instead of ethernet but due to my uni's user/pass 2-step wifi login process I'm unable to make that happen. I've tried what I could by looking around the forums of users who have already had this problem including running dmesg but for some reason my pi wont let me connect to my printer via usb while also being pluged into a keyboard which may have to do with my power supply (Although it says it outputs 5.1V and 2.0A)
Logs (octoprint.log, serial.log)

Additional information about your setup
Printer: CR-10
Firmware: Marlin
Browser: Chrome
OS:Windows 10 Pro
I've restarted my server from scratch so it's essentially just the newest version of the base octoprint image on an sd card, in a pi 3, connected to ethernet.

You can put some tape over the 5V pin of your usb connector.
This way your printer can't power from your pi and it might work when plugged into your keyboard :slight_smile:

(pin 1 is 5V)

but you really should use a sufficient power supply just for your pi.

Hey thanks for the speedy reply, I took your advice and my undervoltage issue has seemed to have disapeared, but I'm still getting the same error when I try to connect.
This time however, i was able to use the keyboard while also being connected via usb to my printer from the rpi, so I tried typing 'dmesg' into the terminal and was able to get this in the last 20 lines:

sudo lsusb

Tried that out:

If there is no power LED displayed on the printer's motherboard (or there is nothing being displayed on a local LCD/TFT screen on it) then it's either not powered or the power switch hasn't been turned on. This would explain everything (to include the under-power condition on the Pi earlier).

If there is a power LED displayed on the printer's motherboard then you might want to remove the tape from the USB connection from before, repeat the dmesg command and see if the printer is detected and reveals a device for the printer at the end.

You might be able to just connect a standard Ethernet cable between the Pi and your laptop; that might actually work to allow you to connect directly and without needing a hub. (In the past, it was necessary to buy a crossover Ethernet cable for doing that.) If this works then you should be able to ditch the keyboard (which is consuming too much power from what it sounds like).

I've kept my printer turned on while i was trying everything out, I connected my computer to the pi via Ethernet and tried the server with and without the tape covering the 5V pin connecting it to my printer's mainboard, but no luck there. Although my printers mainboard LEDs were on as expected, I'll try it out with a different cable between the mainboard and the pi when I get the chance.

Note that printer boards sometimes have a Type B USB connector as well as a Type A connector (optionally). You're definitely interested in the Type B connector on the printer board.

Yeah ive been using the micro-b even before i moved and had this problem, but it could potentially be the cable still.

Just so that we're clear... the microUSB connection on the Pi is for powering it and may not even have data connections in that connector. You would need to connect your printer with a Type-A to Type-B serial cable with internal metallic shielding or a ferrite core.

Sorry for the ambiguity, I'm powering my printer from the wall with what seems to be a sufficient power supply, through a type b micro. I'm connecting my printer's mainboard to my pi with a type b mini that I've used in the past.

I just attempted to connect my pi to a wifi hotspot from my phone but no luck, I think I'm pretty much out of ideas until i can get my hands on another LCD and revert to the old fashioned ways of sd card printing...

So the printer cable has a Type A on the Pi side and a Type B Mini on the printer side. Okay, that should work.

Yeah but that's what I've been doing but nothing has been able to work, I'm still interested in finding a solution to the Ethernet serial port auto-detection problem.

What we know:

  • You're using a Type-A to mini Type-B serial cable to connect your printer
  • Everything seems to work at home over wifi
  • In your dorm room over standard 100Mhz Ethernet, the serial port doesn't get a device issued (nothing in dmesg)
  • You've also introduced a USB-based keyboard at the dorm
  • You have a 5.1V @ 2A power adapter
  • You have a Marlin-based CR-10 and it is powered on
  • Your workstation is Windows 10 Pro
  • OctoPrint 1.3.12
  • Raspberry Pi 3B

What we don't know

  • Whether or not your serial cable has internal metallic shielding or a ferrite core

My gut is telling me it's the keyboard/ethernet pulling down the power/voltage so that it's under-powered. You've indicated that somewhere else this works fine but maybe that was just barely-so, given the power adapter.

Yeah this pretty much sums up the state of things, I'll be getting an official pi3 power supply in the mail soon so I'll be sure to update you on what happens once it arrives.

1 Like

Yeah the new power supply got rid of the voltage issue as expected but did nothing for the connection issue.

Per this thread, do you need drivers for your workstation?

So I just got back to my dorm with the 12V lcd and when i plugged it in, the screen was going crazy which leads me to believe that its been a mainboard problem this whole time.
I'll probably order a nice smoothieboard or something, so hopefully once I get it we can determine if this is actually a connectivity issue.