Recv: echo:busy: paused for user

What is the problem?

I haven't printer anything for a while and I recently came back to my printer and Octoprint.
And now, every time I start a print, I get a "Recv: echo:busy: paused for user" message on the console.
I have never seen that before, and I don't know how to solve that issue.

What did you already try to solve it?

I tried to print directly from the printer screen (from an USB key), without Octoprint and it works like a charm.
I also tried safe mode (see below).

Have you tried running in safe mode?

Yes.

Did running in safe mode solve the problem?

Not really. I don't get the "Recv: echo:busy: paused for user" message anymore, but the print still never starts.

Systeminfo Bundle

Done.

Additional information about your setup

Octoprint 1.9.3, everything is up to date.
Custom printer using a Bigtreetech SKR V1.4 Turbo board.
IMPORTANT: it has been working perfectly with Octoprint for months.

octoprint-systeminfo-20231207115711.zip (282.7 KB)

Hello @emphyrio !

The issue you mention (Recv: echo:busy: paused for user) does not appear in the logs.

Usually you have to hit a button on the printer. OctoPrint just reports that you have to do so.

Can you share the slicer's start gcode and if you have, the start gcode in OctoPrint.


2023-12-07 11:04:20,984 - octoprint.plugins.eeprom_marlin - WARNING - EEPROM output line not recognized, skipped
2023-12-07 11:04:20,984 - octoprint.plugins.eeprom_marlin - WARNING - Line: echo:  M149 C ; Units in Celsius
2023-12-07 11:04:21,173 - octoprint.plugins.announcements - INFO - Loaded channel _plugins from https://plugins.octoprint.org/feed.xml in 0.35s
2023-12-07 11:04:21,631 - octoprint.plugins.eeprom_marlin - WARNING - EEPROM output line not recognized, skipped
2023-12-07 11:04:21,632 - octoprint.plugins.eeprom_marlin - WARNING - Line: echo:  M914 X50 Y50
2023-12-07 11:04:21,660 - octoprint.plugins.eeprom_marlin - WARNING - EEPROM output line not recognized, skipped
2023-12-07 11:04:21,660 - octoprint.plugins.eeprom_marlin - WARNING - Line: echo:  M569 S1 X Y Z
2023-12-07 11:04:21,665 - octoprint.plugins.eeprom_marlin - WARNING - EEPROM output line not recognized, skipped
2023-12-07 11:04:21,665 - octoprint.plugins.eeprom_marlin - WARNING - Line: echo:  M569 S1 T0 E

These commands are not recognized by the firmware.
M569 is RepRap only.

You may check the slicer.


And please turn off the debug logging.

1 Like

Hello,
Sorry for the late answer and thank you for your help.
Here are my answers:

>> The issue you mention (Recv: echo:busy: paused for user) does not appear in the [logs]
But it does on the Octoprint console. Please find a screen copy attached.
Cosole messages

Usually you have to hit a button on the printer. OctoPrint just reports that you have to do so.
I tried to push the printer button, but it doesn't help.
And I don't have any message on the printer screen.

>> Can you share the slicer's start gcode and if you have, the start gcode in OctoPrint.
Here it is :slight_smile: ;Basic settings: Layer height: {layer_height} Walls: {wall_thickness} Fill: {infill_sparse_density}
G21 ;metric values
G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off
G28 X0 Y0 ;move X/Y to min endstops
G28 Z0 ;move Z to min endstops
M205 X8 ;X/Y Jerk settings
G1 Z15.0 F{speed_travel} ;move the platform down 15mm
G92 E0 ;zero the extruded length
G1 F200 E7 ;extrude 3mm of feed stock
G92 E0 ;zero the extruded length again
G1 F{speed_travel}
;Put printing message on LCD screen
M117 Rigibot Printing...

>> These commands are not recognized by the firmware.
>> M569 is RepRap only.
I don't know where this command comes from. It doesn't seem to be in the slicer's start code.

>> And please turn off the debug logging.
How do I do that? Is this an Octoprint setting? I couldn't find it.

octoprint-systeminfo-20231220104317.zip (211.0 KB)
*

Thank you!
Patrick