Remove OctoPrint from SD

What is the problem?

I am trying to remove octoprint from my SD to re install it because I was messing with it and I SSH into it and broke it pretty bad. Unfortunately I have no access to the GUI or anything.

What did you already try to solve it?

I tried to format the SD card and I get an error on windows that it can't be formatted. I tried to delete the partitions on diskpart (cmd) and it deletes them but everything come back again. I then tried to just create a new image with octoprint and when it tries to create the MBR partitions it fails. I then created a Ubuntu image and tried to format the SD card using a Linux distro and still no luck. THe SD card is locked and I cant remove or add anything to it no matter what I do.

Have you tried running in safe mode?

I have no access to Octoprint

Did running in safe mode solve the problem?

I have no access to Octoprint

Systeminfo Bundle

I have no access to Octoprint


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Try to flash the image with the raspberry pi imager


If that still doesn't work I guess your sd card broke and went into read only mode for data recovery.
There is nothing you can do about it if that's the case.

I used that tool originally. I guess the SD is done then. Is it normal for this tool to lock the SDs like that?

The sd card goes into read only mode if the flash is broken so that you can recover the files on it.

No imager should be able to put a card into that mode.

Just one thing I forgot before - you're not by any chance using a micro sd to sd adapter, are you?
Those got a write protect switch most of the time.

Do you put the micro SD card directly into the card reader/writer or do you use an adapter to put the SD card into a normal size slot of the reader/writer?

Like this:


Normal size SD cards and adapters usually have a write protection lever on the side.

No, I am using a USB adapter. I went ahead and got another Micro SD and the software ran without any issues. Thanks for the help.