Rendering problem : wrong directory in Windows

Hi !
Yes i am using windows :wink:

So i've update the two directory and the rendering always end up with error:
Could find no file with path 'C:\Users\XYZ\AppData\Roaming\OctoPrint\timelapse\tmp\octolapse_rendering_tmp\CE3_PS5_vertikal_station_V2.1_PS5_LOGO%06d.jpg' and index in the range 0-

C:\Users\XYZ\AppData\Roaming\OctoPrint\timelapse\tmp\octolapse_rendering_tmp\CE3_PS5_vertikal_station_V2.1_PS5_LOGO%06d.jpg: No such file or directory

So i search in my computer and found the file completely elsewhere :
C:\Users\XYZ\AppData\Local\Packages \PythonSoftwareFoundation.Python.3.8_qbz...\LocalCache\Roaming\OctoPrint\timelapse\tmp

So my solution for now it to copy manually from source A to B and force another rendering.

The Timelapse Folder from the main setting is the same folder as the one from octoprint in the setting itself.

Is there some .yaml file i can check or any other config file i can verify ?

It doesn't look like there are any documented config.yaml options to set the temp folder for timelapses, but that path you mention where you found the files makes me think that is where octoprint is detecting it's base-dir from? Are there other files in there like config.yaml or anything? If not, then this very well could be a bug.

Fixed it by creating the missing folder octolapse_rendering_tmp in C:\Users\XYZ\AppData\Roaming\OctoPrint\timelapse\tmp\ and the rendering is starting now.

Oops forgot to say that it still write the snapshot on the wrong directory in user : AppData\Local\Packages\PythonSoftwareFoundation.Python.3.8_qbz5n2kfra8p0\LocalCache\Roaming\OctoPrint\timelapse\tmp\octolapse_snapshots_tmp

Why it is doing that all the time, i have to move the file on the right directory and render again.

Did you install Python from the Microsoft Store?

i am not sure ? it's there since a long time. And i see python 3.8 in the search bar and i see it appear in a "control panel" way ?

I don't have Windows to check but if you right click Python in the start menu it might mention if it's from the Store. I'm not sure if OctoPrint has been tested when running from Python installed via the Store. If you're willing to go through the effort try installing using the instructions at Setting up OctoPrint on Windows.

I've ran into the same problem, as I am using a store downloaded python for windows version.

I've found a folders menu in the octoprint configurations where you can change the folders for timelapses and other features. In other words, you can change the default path for the one where your octoprint folder actually is.

Somehow, it recognizes the C:\Users\XYZ\AppData\Roaming\Octoprint\ folder as if it was the default path and, therefore, sends the files to the installation path as a default. However, our installation path is in the form C:\Users\XYZ\AppData\Local\Packages \PythonSoftwareFoundation.Python.3.8_qbz...\LocalCache\Roaming\OctoPrint\ and the files get sent there. It seems not to be a problem until Octoprint tries to render the timelapse through FFMPEG and uses the actual C:\Users\XYZ\AppData\Roaming\Octoprint\ folder that's in the folder menu.

This means that you should change all C:\Users\XYZ\AppData\Roaming\Octoprint\ folders to their actual path, C:\Users\XYZ\AppData\Local\Packages \PythonSoftwareFoundation.Python.3.8_qbz...\LocalCache\Roaming\OctoPrint. Eventhough it will mostly change nothing, it will allow the FFMPEG to use the correct folders for rendering.

The thing is that actually changing it can be tricky. Sometimes you might change the folder's path and save, but it will not get stored in the config.yaml. In general, the configurations panel will close when it is able to save the configurations. If it's not closing, try refreshing the octoprint page and trying to change the folders again. This worked for me for every folder except the one that really matters, the timelapse_tmp.

To be sure the changes were saved, open the config.yaml file (it's a text file, might be opened with notepad). There should be a section named folders where the non-default folder paths are stored.

As I've said, I managed to change all paths through octoprint folder config menu but the timelapse_tmp. Then I manually inserted the folder path I wanted ("timelapse_tmp: ...") and saved the file. The purpose of it was trying to force octoprint to read the desired path even if it was not able to save it for some reason. For the changes to take effect I restarted the server and checked if the folder menu was correctly updated.

Now I have just finished my first sucessful timelapse after running into this problem and this is the only fix I tried until now, so hopefully it should work for you too.