Rendering Time-lapse Failed

After Upgrading to Version 1.3.10 I can no longer Render Timelapse. I keep geting the following message.

Rendering timelapse failed
Rendering of timelapse LTAZ52_herringbone_small_gear-1.1-highres_20181217020103 failed with return code 127

/usr/bin/avconv: error while loading shared libraries: /lib/arm-linux-gnueabihf/ invalid ELF header.

As im new to OctoPrint Im at a loss on how to figer out how to solve this problem.

I'm having a hard time finding the exact error/fix in context to avconv. The underlying error seems to suggest that libglib-2.0 isn't correctly installed. Sometimes this is due to a corrupted microSD card.

sudo apt-get update --fix-missing

I'm not sure which package that was included with. This isn't the correct one but I'm researching...

sudo apt-get install --reinstall libcurl3-gnutls  # NOT correct version

OctoPi's build script seems to install these which could be where that comes from:

  • libav-tools, libv4l-dev
  • libjpeg8-dev
  • libjpeg62-turbo-dev

You didn't move your microSD from one Raspberry Pi to another in all this, did you?

LOL that is funny.

I will try your suggestions and let you know what happens.

As for moving the SD card No it has never been used on a different Pi.

I'm having the same issue on a Raspberry Pi that I cloned and then modified for a different printer. I never had an issue rendering timelapses on the original version that I cloned it from. Everything else seems to work great on the cloned version that I modified except it is unable to render timelapses. It gives me the following error every time...

Rendering timelapse failed

Rendering of timelapse JJM_Otyugh_20191011025645 failed with return code 127


/usr/bin/avconv: error while loading shared libraries: cannot open shared object file: No such file or directory

I tried what you suggested by the way and then rebooted the system but it made no difference.

Given the indicated error, I think I would try:

sudo apt-get --only-upgrade install libav-tools

If that fails then it wasn't loaded for some reason. Then you could try:

sudo apt-get install libav-tools
1 Like

Thanks, for the suggestion and redacting my private IP for me.

I'm currently in the middle of a over 2 day long print but once it is complete I will try out your suggestion and let you know if it worked or not.

Well the layers shifted on my print so I had to cancel it, so I was able to try your suggestions but sadly neither of them made a difference. I am still getting that same exact error as before when I try to render one of my unrendered timelapses.

Any other ideas?

The absence of seems to be the problem. An .so file is an object file which results from makeing a project. Something didn't succeed in an earlier step, one would assume.

Possibly removing it first then re-installing it could work. This assumes that I have the correct package that is in question here.

sudo apt-get remove libav-tools
sudo apt-get install libav-tools

If you had a working version of this you might even find out where this lives and then copy it over to the one that's misbehaving. It could be worth, though, grabbing a new microSD card and trying a start from square one.

1 Like