Rendering Timelapse failed with returned error code "None"

Camera model
Logitech C920

What is the problem?
Timelapse fails with no error code mentioned

Example Error: "Rendering of timelapse COLLAPSING_PIRATE_SWORD_small_20200404163307 failed with return code "

What did you already try to solve it?
I have tried updating the camera_usb_options to "-r 1280x720 -f 10" as mentioned in the supported camera section on the octopi wiki.

I researched the octopi.log file and found it mentioning an error related to /usr/bin/avconv. This file does not exist and I imagine it is the root cause of the problem. I do not know how to resolve this issue. I have tried running various apt-get commands. avconv does not have a package and seems to be a part of ffmpeg which is installed and up to date.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)
There is actually no webcamd.log file in the var/log directory. I do see a somewhat related error in the octoprint.log file that I am including.

octoprintlogs.zip (7.2 KB)

Additional information about your setup (OctoPrint version, OctoPi version, ...)
OctoPrint version : 1.4.0
OctoPi version : 0.17.0
Running on Raspberry pi 3
I recently upgraded to those versions by reflashing my SD card per the instructions provided on the Octopi and Raspberry pi sites. Before upgrading I downloaded a backup of Octopi via the web UI. After upgrading I applied the backup. I believe the previous version I was on was 1.3.12. I could not update through the web UI due to issues related to python. So i opted to update by flashing and restoring a backup.

I can't access any octopi pi right now so I'm not sure if this could be backup related.

I would check the ffmpeg path in the recording settings.
Iirc it should be /usr/bin/ffmpeg

which ffmpeg will show you the path in ssh if that doesn't work.

And for the avconv part try sudo find / -name avconv

2 Likes

Thank you for the reply. I think you've set me on the right path for this.

The path for ffmpeg was correct and existed.

avconv could not be found anywhere on the file system.

I took a closer look at the settings in octoprint and found the WebCam & Timelapse settings had 'Path to FFMPEG' set to '/usr/bin/avconv', which the test button failed because the file did not exist.

I changed 'Path to FFMPEG' from '/usr/bin/avconv' to '/usr/bin/ffmpeg'. Clicked test and that it returned successful!

I'm going to be running print jobs tomorrow and will test out the timelapse again.

Thank you for your help!

1 Like

UPDATE: Decided I could just run a short job before hitting the hay. That did it! thanks for the suggestion of looking at the settings for FFMPEG in the web UI.

1 Like