Reprint after cancel

So after I cancel a print, the print turns red in the file menu.. only way to get it to start over is to upload the gcode again.. what am I missing.. is this working as designed there a way to reset that red to black so it can be loaded and printed without uploading again?

Just ignore the color. Black ones have never been printed, green ones were successful last time they were printed, and red ones failed the last time they were printed.

Of course, if the red one failed because of the settings, you may want to adjust the settings in your slicer and upload again. If it failed because of operator error, just launch it again (this happens to me all the time :rofl:).

No, it was canceled.. Started the print and decided to flush the nozzle and canceled the print. ran a few hundred mm of plastic through the extrude and then the only way to print the gcode I canceled was to upload it from my pc again.. Is that normal? If it is already on the pi why can I not just click load and print.. It just does nothing until I upload it again.

Is the state "Cancelling..."?

Not sure but it was at least 10 minutes after .. I had move the extruder and extruded to flush the nozzle.
I will try it again later today and take note..

Gina's posted something in the FAQ regarding that, look for "Cancelling". It's a race condition that can be worked around but it's good to recognize it. I'm guessing it would behave in the way that you're indicating.

That would be

I am not sure this is the issue, and it may be normal functionality. I was under the impression if I was logged into Octoprint I can control the printer from any place I am logged in.. However what seems to be happening is if I login and start a print from computer A and I am also logged in to computer B, I must use the session on computer A if I want control.
I started a print from A, it finished normally and later on I was also logged in to computer B and tried to print again. I could not. I had to go to computer A and was able to click print and all was good. I a going to assume this is working as designed? If I had logged out of A would I have then been able to control from B?

Did you try reloading on computer B?

Yes, it did nothing.

That's not how it's supposed to work.

This is how it's supposed to work.

I suggest you enable serial.log, reproduce the problem and then share that and octoprint.log, that might give us something to work with here.

so my Pi has a head on it.. If I load the file from my pc and it print all is good, If I try and reprint on the Pi desktop, nothing happens.. And nothing in the log..