Resolved...Can see video on one but not both of my computers


#1

What is the problem?
I have a laptop next to my printer and a desktop in the room above. Both can see and print via OctoPrint and the laptop can see the feed from the camera I just installed, however, the desktop only shows a black screen.

What did you already try to solve it?
I have checked the setup for OctoPrint on both computers and they appear to be the same. I have restarted the browser on the desktop machine. Both machines are on the same network.

Additional information about your setup
Both are Windows 10 machines, and I'm using Chrome. I have the PrusaPrint version of OctoPrint 1.3.10, and the latest firmware on my MK3. I have uploaded my OctoPrint log.

octoprint.log (73.0 KB)


#2

I see that you're using a Raspberry Pi Zero W which only has one core (rather than four on the Raspberry Pi 3B). It sometimes can run print jobs but now you're asking it to stream video to not one but two workstations. The inventor of Prusa really didn't understand that the Zero doesn't have the power to do this nor did he understand the Raspi's UART situation.

Replace the Zero with a 3B minimally and you'll be happier with the results over the lifetime of this printer.

Try visiting the webcam directly from upstairs via http://octopi.local:8080/


#3

Thank you for your response. I understand that the Zero is a real weakling, but even without OctoPrint running on the laptop, the video does not show on the desktop. I did the direct connection, but still get a black screen. Must be some issue with the desktop. I'll have to dig deeper.


#4

You might treat this as a name resolution problem at first. If that doesn't help, then try to verify that your upstairs/downstairs are in fact on the same network. Maybe the one upstairs is on the 5Ghz wifi zone and everything downstairs is on the 2.4Ghz zone.


#5

Since neither machine has a problem getting to the server, don't think that is the problem. Anyway, the desktop now sees the video, so nevermind...


#6

Hi @DikH,

could you please tick the box marked Solution beneath the post that helped you? Thanks a lot.


#7

Sorry, looked for it , but didn't recognize that was how mark it as solved.


#8

My guess is that when you did a ping from the problem workstation, it added an entry into that computer's arp cache so that it now works.