RESOLVED: Webcam works with Raspberry Pi OS not seen by OctoPrint

Camera model
EMEET HD Webcam eMeet C960

NOTE: This webcam worked with OctoPrint on a Pi 4B running OctoPi install. This new Pi 4B is running Raspberry Pi OS Bullseye.

What is the problem?
This is a new install of OctoPrint on a Raspberry Pi 4B with 2G RAM. The Pi has new install of "bullseye". I used this guide to install OctoPrint:

Everything works great except the webcam doesn't work with OctoPrint, it does however take images from the command line. (48.1 KB)

What did you already try to solve it?
Google Searches and searching OctoPrint support forum.

I tried URLs in OctoPrint's Stream URL field. My Octoprint is listening on port 5000. I tried:

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

There is no /var/log/webcamd (11.7 KB) (291.2 KB)

Additional information about your setup (OctoPrint version, OctoPi version, ...)
OctoPrint 1.7.3 Python 3.9.2

Did you receive any errors when setting up and installing MJPG streamer and testing it? Did it work when you run the command for that manually?

1 Like

Thanks Charlie. I had not installed MJPG streamer :grinning:

I installed it using this guide and all is working now.


For future reference, or anyone else that comes across this thread - there's a whole section of the install guide titled 'Optional: Webcam' that details all of it.