Router does not see Octopi

**What is the problem?**Router does not see Octopi. Same Raspberry Pi is seen and connects and functions with router as expected.

What did you already try to solve it? I have spent many hours reading and following online instructions from various sources rechecking editing of octopi-wpa-supplicant.txt numerous times. Used Nano editor to recheck contents of said file and cannot find anything typed incorrectly. Also tried adding network info at end of the file as suggested by one source to no avail. Raspi-config is of no help.Downloaded 2019-09-26-octopi-buster-lite-o.17.0 twice used Etcher to flash 2 different 32G SD cards all giving same results.

Logs (syslog, dmesg, ... no logs, no support) I don't know how to get log files from Octopi attached to this message since I cant connect the Octopi to the router.
Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)I am trying to connect Octopi on a Raspberry Pi v4 to a Netgear R7000 router which has no problem with any other device except the PI with Octopi on it's SD card. I was hoping I might get some help as to what to look for in the logs and find out if there is a way to suspend output to my monitor during boot up so I can see what is happening. Also if I could suspend output or print from the PI the output from wlan0 scan I could see what the ESSID information is in first 2 cells. My router broadcast two network names Netgear77 and Netgear77-5G. I don't know why that is because no device that I have tries to connect to the latter they all connect at 2.4. The SSID in octopi-wpa-supplicant.txt is Netgear77 and county is US Any help would be greatly appreciated as I would very much like to control my Prusa mk3s with Octoprint or anything I could use to use for control. Many thanks for your time and attention .


Hi :slight_smile:

I edited your post and removed the email address because I don't want you to get spammed.

You wrote

does that mean you edited the file with an other editor and checked it with nano later?

Many thanks on removing e-mail. I did not think about spam. I edited the txt file with Notepad++ and wrote it to sd card. When after numerous attempts to rewriting the file and checking for typos and not finding anything wrong I did another search using different words in the search for describing my problem and one answer was to simply edit the file on the sd card in real time after booting Octopi using the Nano editor and putting the ssid and psk info at end of thr text file. That did not solve my problem either. So far all answers to to my search address the problem of connecting Octopi to a network involve a remote computer not seeing Octopi and not a router not seeing Octopi, except for physical difficulties with hardware which I am not having.. I am most appreciative for you taking the time to respond

Did you try to flash a new image and start over?
Maybe something got mixed up in the file and it doesn't work anymore. It can be picky sometimes :smiley:

Did you set the country code?
Without that in the wpa_supplicant file you won't get any WiFi connectivity. and if it's set to the wrong country, you may not be able to connect as the channels are different

Problem solved. I do not remember seeing in the instructions to take note that the ssid in wpa-supplicant is case sensitive. I found out the hard way after much frustration. Someone did mention to make sure that you don't change your country id to lower case but nothing regarding network ssid.. When I would use nano to see the ESSID in the wpa-supplicant file I would see 'NETGEAR77' and 'US' for country..
However when I would edited the wpa-suppicant file on the sd card I typed 'Netgear77'.My router broadcasts NETGEAR77 and because ESSID said NETGEAR77 I thought all was well. Sigh, Oh well. Thanks to all for the efforts to help

I had replied to one of you and I thought I had seen that reply in this thread but don't see it now so if I am repeating myself I apologize. Does anyone know how to suspend the output to a monitor from Octopi booting up so you can see all that occurs?

login via ssh or console and enter dmesg
when you're on the console you probably can't see all the lines.
Use dmesg | less in that case and scoll line by line with enter and page by page with the spacbar.

thanks to @MMcLure and cmdrcody