Rpi Cam v2 not working with Rpi Zero 2 W

Camera model

Raspberry Pi Camera Module V2

What is the problem?

The camera is not working with Rasberry Pi Zero 2 w

What did you already try to solve it?

tried safe mode, tried restarting Pi, and made sure the ribbon cable was connected correctly on both sides

Have you tried running in safe mode?

yes

Did running in safe mode solve the problem?

no

Systeminfo Bundle

Additional information about your setup

OctoPrint version 1.10.2, OctoPi version 1.0.0, Sovol Sv06 printer, marlin firmware, google browser, operating system Windows 10

also, I am using a 500mm 15-pin to 22-pin ribbon cable to connect the Rpi and Cam and it doesn't have the "black electromagnetic shielding film" on it even tho the Amazon listing said it did and from shipping the cable is bent in multiple places but I don't see any damage that looks like the cable is broken so I don't know if the problem could be the cable.

I have an RPi Cam V2 working on a Zero W. Unfortunately I'm not in a position to share my configuration this week. I have a reminder set to check to see if there is an answers posted next week.