RPi not finding SKR Mini E3, no serial connection

What is the problem?

My new Pi Zero 2W doesn't see the BTT SKR Mini E3 v2 in my Ender 5. Serial connection not detected. "Could not autodetect your printer. No working connection parameters could be found."

What did you already try to solve it?

Port is identified as /dev/ttyS0, baudrate 115200
Tried 4 different USB cables. Tried all baud rates. Checked OTG converter is working correctly.
lsusb shows: Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
added additional serial ports:
/dev/ttyUSB0
/dev/ttyACM0
Tried "Apply parity double open workaround" to 'Never'
Turned off: Request exclusive access to the serial port
Dmseg; See below

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

octoprint-systeminfo-20231008103321.zip (17.9 KB)

Additional information about your setup

Terminal output shows this: Unexpected error while connecting to serial port /dev/ttyS0, baudrate 115200 from hook default: error: '(22, 'Invalid argument')' @ comm.py:_open_serial:3916

After changing "Apply parity double open workaround" to 'Never' terminal shows:
There was a timeout while trying to connect to the printer
after 15s
Then:
No answer from the printer within the connection timeout, trying another hello
Dmseg:
[ 3.199955] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 6.01
[ 3.204184] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 3.206430] usb usb1: Product: DWC OTG Controller
[ 3.208641] usb usb1: Manufacturer: Linux 6.1.21-v7+ dwc_otg_hcd
[ 3.210903] usb usb1: SerialNumber: 3f980000.usb
[ 3.213782] hub 1-0:1.0: USB hub found
[ 3.216002] hub 1-0:1.0: 1 port detected
[ 3.218681] dwc_otg: FIQ enabled
[ 3.218691] dwc_otg: NAK holdoff enabled
[ 3.218699] dwc_otg: FIQ split-transaction FSM enabled

Hello @Brushless !

Sorry, this no networking issue. Networking is LAN, WiFi/WLAN, Router etc

I'll move the thread for you.

1 Like

I wouldn't do that - you will never know if the ports are detected if you add them permanently.
Just my opinion.

Pretty sure the dmesg snippet you posted is just about the internal usb controller of the pi and is part of the booting log.
If you want to check dmesgfor activity I would wait until the pi is booted up and then enter dmesg -wfor a continuous output. Then you can try multiple cables easily.

Now back to you problem - let's check one of the most common mistakes with a pi zero:
Did you use the correct usb port? It's the inner one.

You can power the pi with either of the ports, but just one has usb functionality.

Thank you, reading what you said I was hopeful that it was something as simple as using the wrong port but I tried it again just now and it's still not connecting. Getting this on terminal:
Send: N0 M110 N0125
No answer from the printer within the connection timeout, trying another hello
Send: N0 M110 N0125
dmes
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

If I dmesg -w and unplug/plug the USB in I get this:
[ 409.013992] usb 1-1: USB disconnect, device number 2
[ 411.463917] Indeed it is in host mode hprt0 = 00021501
[ 411.673848] usb 1-1: new full-speed USB device number 3 using dwc_otg
[ 411.674039] Indeed it is in host mode hprt0 = 00021501
[ 411.914654] usb 1-1: New USB device found, idVendor=1eaf, idProduct=0004, bcdDevice= 2.00
[ 411.914676] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 411.914686] usb 1-1: Product: Maple
[ 411.914693] usb 1-1: Manufacturer: LeafLabs
[ 411.915471] cdc_acm 1-1:1.0: ttyACM0: USB ACM device

So it looks like a ttyACM0 device, so do I presume I need to change my port from a ttyS0 to ttyACM0?

I changed additional serial ports:
/dev/ttyUSB0
/dev/ttyACM0
to
/dev/ttyACM*
and set Serial Ports to AUTO and now it's working!

Thank you, sorted!

2 Likes

Alrighty
Glad it's working

Just FYI
ttyS0 is the internal serial port. It's only used when you wire the Tx and Rx directly to the gpio pins of the pi.

Happy printing :tentacle:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.