RPi ‘stops’ during boot cycle

I have been trying to setup my RPi to run Octoprint without success. If I flash a SD card, add ssh and the network info and plug into a either a Pi Zero or a RPi 3B, the Pi starts its boot sequence and then just stops.

Sometimes it gets all the way through and then just stops, but normally it is ⅔ way through boot sequence and stops with various errors, one being Unhandled Fault: vector encryption! I have also attached some images of what appears to be a kernel dump and other error messages I get as it boots up.

Initially I thought the issue was the Pi Zero, but I have also tried a RPi 3b.
I have tried 2 SD Cards, a brand new 8GB and an existing 16GB
I have tried downloading a new image which is burnt onto the SD card using Balena Etcher on a MacBook Pro.

I am unable to use Safe mode as the web never gets up long enough for me to select it.

I am unable to access the logs as the system is not running long enough.

Version used OctoPi v0.17.0

I am at a complete loss on how to resolve this, without logs or any way of getting information from it, I am at a complete loss.!

At this point the Pi is frozen, no webpage, no command prompt or anything.

To rule out an OctoPi issue, I suggest trying to see if you can boot the latest Raspberry Pi OS, which can be found https://raspberrypi.org/downloads.
If that does work, then we can look further into why OctoPi doesn't seem to work for you.

So I have done some further tests that may explain my conundrum.

If I start with a Pi 2B (Yes I have one that old) it appears to work ok, but this doesn’t have a Pi Camera fitted. I was able to run through the setup on the web page and it all appeared to be ok.
If I use the Pi Zero, it starts, allowed me to ‘cat’ the log, the webpage never runs and then it just hung.

Both Pi’s work fine on a Raspbian build of varying types - I have several for different projects that are ongoing at the moment.
I have tried moving the camera to the Pi 2B and this also works.

It looks like adding the Pi Zero into the mix is the issue. Looks like I am going to need to print an enclosure for my Pi and find a solution to the power needs.

It would appear the spirits of the forum have fixed my issue - something we all know that regularly happens - as soon as you post something on the forum it starts working!

1 Like