RPi Zero 2 not connecting to Prusa Mk3s or Webcam

What is the problem?

Initially my Webcam stopped working which I assumed was due to the ribbon cable coming loose after moving my printer into an enclosure in my garage.
I tried the connections, but decided to rebuild my Raspberry Pi Zero 2W completely from scratch. Using Raspberry Imager I did a fresh install, followed the Prusa guide for setting up as it is plugged directly into the main board and I had no connection to the printer at all and no web cam

What did you already try to solve it?

Rebuilt Pi Zero2 several times, including a completely fresh install that went through the initial Setup script
Followed this guide with all optional settings Octoprint - Configuration and install | Prusa Knowledge Base
Removing the camera completely
Checked serial ports /dev/ttyAMA0 and /dev/s0 exist

Added the following to boot/config.txt


I am beginning to wonder if my Zero 2W has a fault, as I can’t get either the webcam or the serial port to work.

Have you tried running in safe mode?

Yes, made no difference

Systeminfo Bundle

serial.log (148 Bytes)
octoprint.log (47.8 KB)
tornado.log (22.0 KB)
haproxy.log (40.5 KB)
webcamd.log (2.3 KB)

System Info

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.5 Safari/605.1.15
connectivity.connection_ok: True
connectivity.enabled: True
connectivity.online: True
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1000.0
env.hardware.ram: 380948480
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi Zero 2 W Rev 1.0
env.plugins.pi_support.octopi_version: 1.0.0
env.plugins.pi_support.octopiuptodate_build: 1.0.0-1.9.0-20230523082504
env.plugins.pi_support.throttle_check_enabled: True
env.plugins.pi_support.throttle_check_functional: True
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 22.3
env.python.version: 3.9.2
env.python.virtualenv: True
octoprint.last_safe_mode.date: 2023-06-18T09:21:19Z
octoprint.last_safe_mode.reason: settings
octoprint.safe_mode: False
octoprint.version: 1.9.0
systeminfo.generated: 2023-06-18T09:44:02Z
systeminfo.generator: zipapi

ssh in and do sudo raspi-config
Go to interfaces, serial port. Tell it no for console, but yes for hardware.
Make sure you have it wired correctly, and don't have Rx and tx swapped

and make sure Pi Zero support is enabled on the printer

Hi, you’re right the Pi Zero didn’t have enough power to run OctoPi, but the Pi Zero 2W is much more powerful and was working fine for a very long time.

After connecting another Pi is the USB lead, checking that the USB port on the printer works by refreshing the firmware, I am still struggling.

In the logging I am seeing:
2023-07-02 12:35:34,335 - octoprint.util.comm - INFO - Changing monitoring state from "Offline" to "Opening serial connection"
2023-07-02 12:35:34,344 - octoprint.util.comm - INFO - Connecting to port /dev/ttyACM0, baudrate 38400
2023-07-02 12:35:34,373 - octoprint.util.comm - INFO - Changing monitoring state from "Opening serial connection" to "Connecting"
2023-07-02 12:35:34,382 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2023-07-02 12:35:34,432 - octoprint.server - INFO - Autorefresh of serial port list stopped
2023-07-02 12:35:37,202 - octoprint.util.comm - WARNING - Received line:
2023-07-02 12:35:37,203 - octoprint.util.comm - WARNING - | J‘Á!*0͒ÚAH \x00’
2023-07-02 12:35:37,203 - octoprint.util.comm - WARNING - The received line contains at least one null byte character at position 16, this hints at some data corruption going on
2023-07-02 12:35:37,224 - octoprint.util.comm - WARNING - Received line:
2023-07-02 12:35:37,225 - octoprint.util.comm - WARNING - | 0©ÉÛ\x00J‚VÑÞ ,`\x00ÁíP÷Í\x002DhÙ
2023-07-02 12:35:37,226 - octoprint.util.comm - WARNING - The received line contains at least one null byte character at position 4, this hints at some data corruption going on

no idea how or why there is a null byte character, any ideas?

Have you set OctoPrint to a fixed baudrate?

sorry i deleted it by mistake

this has been solved by:-

Replace Zero 2W with a Pi 3B
reflash the SD card
run through setup again
Webcam still not working - suspect web cam has failed

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.