RPI4 missing USB C socket

What is the problem?

Hi, today I got a RPI 4 out of my parts draw and it is missing its USB C socket. It must never have had one, but I bought it over a year ago, so I guess it's out of warranty.,

What did you already try to solve it?

I've ordered some new sockets on Ebay, but I'm a bit worried about soldering such a small connection by hand.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I'm wondering if I can use an alternative method to power it. I don't actually need USB C for anything else?

As far as I know, there are two other ways of powering a rpi4. One of those is with a PoE Hat for the rpi4 (Buy a PoE HAT – Raspberry Pi), or powering it through the gpio pins (see diagram below).

Both pins 2 and 4 should be connected to 5 volts, you can use any one of the pins, but it is advisable to use both pins as if one pin is unable to provide accurate 5 volts the other pin can compensate for that.

1 Like

Can't answer for the PoE hat, but I believe the power from the GPIO pins doesn't go through all the power protection stuff on the Pi, so be careful not to accidentally get it wrong while wiring & avoid cheap power supplies more likely to surge.

1 Like

Thanks for those replies. I tried powering it using a regulated bench top power supply set to 5v. I used one of the 5v GPIO pins and a GND down at the far end of the header. The RPI powered up and seems to work well, although it is reporting low voltage in Octoprint. I was only using alligator clips to carry the power, so I'll try something a bit more permanent now.
Thanks again

I ended up finding a li-polymer hat, which has a usb C power input. I don't really need the hat, but it solves my power issues. Thanks again.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.