RPI4 starts reporting errors on terminal to FFCP midprint and stops

What is the problem?
My 3D print starts on my Flashforge Creator Pro and after about two layers it starts reporting Syntax warnings in Octoprint terminal window

What did you already try to solve it?
I tried re-flashing Octoprint with no success and even took the backup of an RPI3B+ that had no issues with the same FFCP and uploaded it to the RPI4. It successfully printed a bed level test pattern but when I tried a larger (taller) print, it printed a couple layers and stopped mid layer. When the print stops, Octoprint hangs in Canceling state and I have to power cycle the printer to get them to sync again. With the gcode errors, I tried switching the gcode flavor from RepRap to Makerbot in the GPX plugin with no difference. Not sure where to turn to now but it seems the Octoprint is talking faster than the FFCP can keep up. I also have a setup with another RPI4 talking to an Ender 5+ with no problems.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

Partial log

Recv: // echo: (line 9) Syntax error: unrecognised gcode '% L=-/60*77'
Send: N10 M117 0% L=-/252*70
Recv: // echo: (line 9) Syntax warning: unsupported mcode command 'M1170'
Recv: ok
Recv: // echo: (line 10) Syntax error: unrecognised gcode '% L=-/252*70'
Recv: // echo: (line 10) Syntax warning: unsupported mcode command 'M1170'
Send: N11 M117 0.01p  complete*82
Recv: ok
Send: N12 G92 Z-5*67
Recv: // echo: (line 11) Syntax warning: unrecognised command word 'c'
Recv: // echo: (line 11) Syntax warning: unrecognised command word 'o'
Recv: // echo: (line 11) Syntax warning: unrecognised command word 'l'
Recv: ok
Recv: // echo: (line 12) warning G92 emulation unable to determine all coordinates to set via x3g:140 set extended position

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)
I am using Octoprint 1.3.12 with octopi Version 0.17.0, running on Raspberry Pi 4 Model B Rev 1.1
Interfacing with the RPI4 on a windows machine over wifi using Firefox browser.

octoprint.log (295.9 KB)serial.log (148 Bytes) plugin_GPX.log (5.3 KB)

Hi :slight_smile:
If you open the serial.log you will find a special message - just for you :wink:

I'm not familiar with the GPX plugin but the log says
Configuration error: Ignoring configuration value 'None'
How did you configure the plugin?

I got the Flashforge Creator Pro to work at one of my previous contracts. See the table here and scroll to the far right to see what I had to do. I would recommend using one of the USB v2 connectors on the Pi4B.

1 Like

@PrintedWeezl noticed that too. I used the same GPX config that I used with the PI3B+, but specifically the only entries in the config window that are blank are "Show pre-release updates ", "Verbose GPX logging -Warning", "Nominal filament width:", "Actual filament width:" and "Packing density:". I am not sure what Packing density is referring to.

@OutsourcedGuru - Thanks for the input. The only difference I had with your table was the Max X speed and inverted. I will try those changes and see what happens.

You noticed the part where it said only-print-from-SD, right?

Which "it" are you talking about?

The far right of the table of printer profiles. I was never able to stream from OctoPrint to this printer; it throws odd errors.

I did not see that but, I have not had any issues using a PI3B+ with the FFCP for the last three years. I just wanted to upgrade to a PI4 because it is much faster starting up and transfering files. Execution should be the same, but for some reason after a few layers the FFCP and PI4 start having I/O errors.