Runout Switch not respected, sometimes

What is the problem?

I have a BTT 1.3 with tmc2208s mainboard and it runs my ender3 fine. Odd thing is sometimes the printer stops the second the switch is activated, and sometimes it lumbers on. It's kind of irritating to rely on something that may function.

What did you already try to solve it?

It's little indicator light goes on and off so I know it's got power. I also checked the LCD menu and config had it enabled.

Scratched butt. Actually it's worked on and off without an apparent reason but I'm depressed so I could miss a pink elephant in the same room. The machine is actually pretty turned, it's precise as hell and trammed within 15um. I have one-touch grid printing for that.... What I never do is print direct from SD, of course I figure it would work then but what's the point? Unless you live in a area with sketchy AC...

heres how dumb I am. I wasted 3 nights printing lithophanes and having massive shifts. I then think hey, I put that fancy tensioner on when this all started going south and maybe its just TOO tight. Yep.

Have you tried running in safe mode?

I didn't but I think that would cause it to not (70.3 KB)

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Marlin firmware - i made numeric changes ONLY to cfg files on a BTT 1.3 with TMC2208, Using chrome on windows 10. Cura 4.1.1 (tried 412, crashed). cone (1).gcode (3.4 MB) - theres the gcode, only thing of note was i used USB keyboard plugin just prior this time to pulling switch - i turned speed down to 50% with a command mapped to M220 S50 | M300 Pwhatever

Do you have HOST_ACTION_COMMANDS enabled in Marlin?

Charlie_Powell.. sorry I believe I do. I haven't messed with FW for a few months. Anyhoo - It worked and paused the printer just a minute ago and great, then it loses Z homing. It resumes crashing into the print making god awful noise and I M112 the hell out of it.

No I had the darn thing mapped to M815. No clue what that is, that's the problem with macros.

OK running thru config, i allowed the Z to idle and drop into the bed