S7 Samsung S7 edge for Android not connecting

Hi, I know Octoprint for Android is not directly connected to Octoprint but thought I'd post a question here about the above in the hope someone moving in this sphere might have some input.

I've got two Samsung S7 Edges sitting in my draw, running Android Ver 8.0.0. These should be ideal, I would have thought, for running Octo for Android. Octoprint for Android installed OK and I downloaded add-ins etc as per one of the YouTube vids on Octoprint for Android site. But while I could connect the phone to my computer normally via a USB cable as it should, I couldn't get it to connect to the 3D printer, my computer, or pull up anything on the web when I typed the IP address from the Octo Android app, or charge.

I tried several OTG cables, a Y cable, and a Targus powered USB hub, and the original Samsung USB adapter. I tried changing various USB settings on the phone including the ones in Developer Options. Nothing would connect or power the phone. A wireless charger worked as it should.

I see some S7's in the Excel list of phones on the Octo Android site, and some seemed worked and some didn't. I didn't really understand some phones for running different versions of Android with names I didn't recognise.

Any ideas?